Certbot authorization error while creating certificate: nvalid response from

I am trying to obtain certificate for my domain using the command

sudo certbot certonly -w . -d mydomain.com

I can access the file created inside ./wellknown/acme-challenge/test

Can someone point me to what am I doing incorrect?
mydomain.com is not actual domain and I use my actual domain while running command

If you hide your domain, there’s little we can do to assist you.

Based on your error, the most likely guess would be that your domain is setup with IPv4 and IPv6 addresses, but the IPv6 address points to the wrong server or isn’t properly routing to your virtual host.

-w . is a bit risky as well, it’s better to use an absolute path.

Hi @test

why is there a file? That must be a folder.

Rename the file (file name 1234), then create the subfolder acme-challenge, then move the file 1234 in that subfolder.

Then try to load that file via


What's the complete path of that file? Use the first part (without .well-known/acme-challenge) as -w parameter.

PS: Ipv4 and ipv6 have the same http status 404 checking a not existing file. So that looks good.

That may be the problem.

Hey @JuergenAuer, couldn’t follow your suggestion

do you suggest to specify the complete path
sudo certbot certonly -d zoodly.uz/.well-known/acme-challenge
instead of
sudo certbot certonly -d zoodly.uz ?

No, your first command is incomplete.

Must be

sudo certbot certonly --webroot -w yourWebroot -d zoodly.uz

yourWebroot must be the local path in your filesystem.

The test file works -> so you have found your correct webroot. Then use it.

Please share your complete command. And the complete path of your test file .well-known/acme-challenge/1234

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.