Cerbot Installation Error

I am trying to install certbot on my macOS Sierra mac. I have python3 installed and up to date.

$ brew install certbot
==> python3 -c import setuptools... --no-user-cfg install --prefix=/usr/local/Ce
Last 15 lines from /Users/serveradmin/Library/Logs/Homebrew/certbot/28.python3:
__file__ = 'setup.py'
exec(compile(getattr(tokenize, 'open', open)(__file__).read()
  .replace('\r\n', '\n'), __file__, 'exec'))

Traceback (most recent call last):
  File "<string>", line 3, in <module>
  File "setup.py", line 31, in <module>
    from setuptools import Feature
ImportError: cannot import name 'Feature' from 'setuptools' (/usr/local/lib/python3.8/site-packages/setuptools/__init__.py)
1 Like

I think you should try reporting this to https://github.com/Homebrew/homebrew-core/issues , where the maintainers of the Certbot formula will see it. (Perhaps read https://docs.brew.sh/Troubleshooting first).

Apparently it is related to a feature removal in setuptools: https://github.com/pypa/setuptools/issues/2017 and the solution would be to pin the setuptools version. It seem that a similar change was made to linuxbrew in the context of the same issue, but nothing for macOS.

FWIW installation works for me in Catalina.


I tried the solution on that GitHub issue link. Got the same error. I can’t report to homebrew because they stopped supported Sierra. I will update to High Sierra and see if it works.

1 Like

Updated to High Sierra and ran brew upgrade then brew install certbot and it worked. Thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.