Can't suddenly issue/renew certificate (cerbot) nor issue (gethttpsforfree)

Please fill out the fields below so we can help you better.

My domain is:

I ran this command: certbot certonly --webroot -w /var/www/acme-challenge/ -d

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Starting new HTTPS connection (1):
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /var/www/acme-challenge for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching Error getting validation data


My web server is (include version): nginx/1.11.1

The operating system my web server runs on is (include version): CentOS Linux release 7.2.1511 (Core)

My hosting provider, if applicable, is: selfhosted

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

I’ve been using LE (with certbot) without an issue for over a year now, and sometimes, I used gethttpsforfree to get some certificates, without an issue.

Yesterday I try to issue a certificate for this domain (a new subdomain. I have certificates for others subdomains in this same domain) and I run into this error I describe. For discarding other issues, I try a certbot renew --dry-run which for my surprise not just doesn’t works but returns the same error for the two others subdomains (renewal was functioning OK and ) and the Nginx vHost configuration wasn’t changed.

I verify all possible things, the fqdn points to the right IP, my nginx is serving correctly, and I can serve content from the webroot path provides. I manually create the acme-challenge folder and place a file inside it and I can correctly display it (firefox, curl).

After testing many Nginx configurations, with that domain and other domains (just for trying, since I verified I could serve from that path) I ditch cerbot and try gethttpsforfree, since I really need this certificate sooner than I’d like a proper cerbot functioning. For my surprise, gethttpsforfree doesn’t works either (first time that happens for me)

In the latter case, it fails in the final step (5) giving me this error:

Error: Domain challenge failed. Please start back at Step 1. { “type”: “http-01”, “status”: “invalid”, “error”: { “type”: “urn:acme:error:connection”, “detail”: “Fetching Error getting validation data”, “status”: 400 }, “uri”: “”, “token”: “sXBC5SDxNBxI8cT8-Iem7MlQXXlFRvq-MjjD3Fpxf2g”, “keyAuthorization”: “sXBC5SDxNBxI8cT8-Iem7MlQXXlFRvq-MjjD3Fpxf2g.x9d1J2bFWc9o7DthOIoRmUFXxzNP_pwtaNMMJRNgvZk”, “validationRecord”: [ { “url”: “”, “hostname”: “”, “port”: “80”, “addressesResolved”: [ “” ], “addressUsed”: “”, “addressesTried”: [] } ] }

I choosed to serve the file with the python simple http server (I’ve always done that way) and it seems I get a request: - - [29/Jun/2017 12:22:30] “GET /.well-known/acme-challenge/sXBC5SDxNBxI8cT8-Iem7MlQXXlFRvq-MjjD3Fpxf2g HTTP/1.1” 200 -

I also open the URL ( in a browser (Firefox, private mode) and get a response:

So, at this point I don’t know where to look at. Any tips?

The only major change in the server configuration was upgrading PHP (5.4 to 7.1)
I also updated cerbot to the last version in my repo: 0.14.1

Thanks for reading!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.