Can't seem to have 2 certificates at once

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: samuele.site, dbdstats.site

I ran this command: sudo certbot certonly --standalone --agree-tos --preferred-challenges http -d dbdstats.site

It produced this output: `Press Enter to Continue
Waiting for verification...
Cleaning up challenges

IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/dbdstats.site/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/dbdstats.site/privkey.pem
    Your cert will expire on 2021-09-08. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot
    again. To non-interactively renew all of your certificates, run
    "certbot renew"

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let's Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le
    `

My web server is (include version): Apache 2

The operating system my web server runs on is (include version): Ubuntu 20.04

My hosting provider, if applicable, is: rhosting.it

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): can do that if I want

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.40.0

As said in the title, I had a domain: samuele.site that had a working ssl certificate, as soon as I registered this new one: dbdstats.site, none of them will work. The working one before stopped wirking now and the other one is not working at all.

This command would only get you a certificate and does not interact with your webserver. Any issue you're having is most likely due to your Apache configuration, which is not touched by certbot with the certonly subcommand and the standalone authenticator.

I ran all of this commands, with dbdstats.site instead of your-domain.com

I think I fixed it now and got this messag:

Your existing certificate has been successfully renewed, and the new certificate
has been installed.

The new certificate covers the following domains: https://dbdstats.site and
https://samuele.site

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=dbdstats.site
https://www.ssllabs.com/ssltest/analyze.html?d=samuele.site

But only samuele.site seems to work and is the only one "secure"

Turns out is my chrome that kept not secure in cache, everythings fine, thank you all :slight_smile:

Just kidding, it is secure for some people and not secure for others, any help?

All looks good if you look at the SSLLabs links above.

Please provide detailed information of the error some people get, with screenshots and certificate info from their browser.

Some people get redirected to https:// and some doesn't, same browser on same settings