Cant renew my certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot renew

It produced this output:

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)

1 renew failure(s), 0 parse failure(s)


  • The following errors were reported by the server:

    Type: connection
    Detail: Fetching
    Error getting validation data

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you're using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.
    My web server is (include version): nginx (1.14.0)

The operating system my web server runs on is (include version): ubuntu 18.04

I config my nginx below:

server {
listen 80 default_server;
listen [::]:80 default_server;
root /var/www/html;
return 301$request_uri;
server {
listen 443 ssl;
location / {
proxy_pass http://localhost:5000;
proxy_http_version 1.1;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection keep-alive;
proxy_set_header Host $host;
proxy_cache_bypass $http_upgrade;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;

listen 443 ssl; # managed by Certbot

ssl_certificate /etc/letsencrypt/live/; # managed by Certb$
ssl_certificate_key /etc/letsencrypt/live/; # managed by Cer$
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

My DNS config:

Your server is just not accepting TCP connections on port 80 (http). That's required in order to be able to complete an http validation. So you need to open that port on any firewalls or network configurations you have.

1 Like

Hi @webprofusion,
I opened port 80, you can see status below

Status: active

To Action From

80/tcp ALLOW Anywhere
443/tcp ALLOW Anywhere
80 ALLOW Anywhere
22/tcp ALLOW Anywhere
Nginx Full ALLOW Anywhere
443 ALLOW Anywhere
80/tcp (v6) ALLOW Anywhere (v6)
443/tcp (v6) ALLOW Anywhere (v6)
80 (v6) ALLOW Anywhere (v6)
22/tcp (v6) ALLOW Anywhere (v6)
Nginx Full (v6) ALLOW Anywhere (v6)
443 (v6) ALLOW Anywhere (v6)

Ok, I can't request (and there is no response on tcp port 80), so either:

  • something else is blocking port 80
  • there is nothing listening on port 80
  • you are blocking traffic geographically

Either way, until you can communicate with your server via http Let's Encrypt won't be able to perform http validation.


Thank you so much for your information. I will find out whats happen. I can connect through 443 but 80. I will update my post if i figure out what happened.

1 Like

I found problem, port 80 being blocked by iptables


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.