Can't obtain certificates


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: chilli.ai

I ran this command: certbot certonly
Saving debug log to /var/log/letsencrypt/letsencrypt.log

How would you like to authenticate with the ACME CA?

1: Spin up a temporary webserver (standalone)
2: Place files in webroot directory (webroot)

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2
Plugins selected: Authenticator webroot, Installer None
Please enter in your domain name(s) (comma and/or space separated) (Enter ‘c’
to cancel): chilli.ai, www.chilli.ai
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for chilli.ai
http-01 challenge for www.chilli.ai
Input the webroot for chilli.ai: (Enter ‘c’ to cancel): /var/www/chilli.ai

Select the webroot for www.chilli.ai:

1: Enter a new webroot
2: /var/www/chilli.ai

Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2

It produced this output:

Waiting for verification…
Cleaning up challenges

Failed authorization procedure. www.chilli.ai (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.chilli.ai/.well-known/acme-challenge/Vzk1FKfjEfP5DbKBa9kuHpdTpDBXysmQnUZGJI5SJTY: "


<meta name=“viewport” content=“width=device-width, initial-scale=1.0, user-scala”, chilli.ai (http-01): urn:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://chilli.ai/.well-known/acme-challenge/Zcf2XkgOlCEIXGL8OKgPQuLgMJione6uUWyYOf68tJg: "


<meta name=“viewport” content=“width=device-width, initial-scale=1.0, user-scala”

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: www.chilli.ai
Type: unauthorized
Detail: Invalid response from
http://www.chilli.ai/.well-known/acme-challenge/Vzk1FKfjEfP5DbKBa9kuHpdTpDBXysmQnUZGJI5SJTY:
"


<meta name=“viewport” content=“width=device-width,
initial-scale=1.0, user-scala”

Domain: chilli.ai
Type: unauthorized
Detail: Invalid response from
http://chilli.ai/.well-known/acme-challenge/Zcf2XkgOlCEIXGL8OKgPQuLgMJione6uUWyYOf68tJg:
"


<meta name=“viewport” content=“width=device-width,
initial-scale=1.0, user-scala”

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address.

My web server is (include version): Hiawatha v10.8.1

The operating system my web server runs on is (include version): Fedora Workstation 28

My hosting provider, if applicable, is: namecheap.com

I can login to a root shell on my machine (yes or no, or I don’t know): yes, and the commands were run as root.

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): NO.

DNS Settings on name cheap are:
A-record: host = @ value
A record: host = www value

Many thanks for any help that you can give me :smile:


#2

Hi @jamesth

please create a subdirectory /.well-known/ and the next subdirectory /.well-known/acme-challenge/

Then create a file without file-extension (name like 123456789, not 123456789.txt), save the file in the /.well-known/acme-challenge/ - directory.

So you can test with your browser, if the file is send correct.

That may be something like

/var/www/chilli.ai/.well-known/acme-challenge/123456789


#3

Your webserver seems to return the same page no matter what URL you give it:

http://chilli.ai/this-certainly-should-not-exist

You’ll need to configure it not to do that in order to get webroot verification with certbot working. If you’re not sure what’s wrong, you could share your webserver configuration, but we don’t have a whole lot of Hiawatha users so I can’t guarantee that anyone will be able to help you. You might have better luck on Hiawatha’s forums.

By the way, Hiawatha has semi-native support for Let’s Encrypt that might be easier to use:

https://www.hiawatha-webserver.org/letsencrypt


#4

Hi,

Thank you everyone for your help :slight_smile: I solved it, it was me being an eejit!

The letsencrypt script asked me for the path to the website, and I put in /var/www/chilli_ai.
The actual path is /var/www/chilli_ai/Public once I did that everything worked as expected :smile:

Many thanks once again!


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.