Can't install cert on Debian 10 & Apache2 with Nginx on same server

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

I know the previous admin has installed Letsencrypt certi fo Nginx, but I need Apache certi. The previous certi is visible in the log files. I tried this on to identical machines where both times it is the same outcome. Please advice.

My domain is: http://81.19.123.73/ valoliitto.fi

I ran this command:
COMMANDS TO INSTALL ============
sudo apt install snapd
sudo snap install core
sudo snap refresh core
sudo snap install --classic certbot
sudo ln -s /snap/bin/certbot /usr/bin/certbot
sudo certbot --apache

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log

The requested apache plugin does not appear to be installed

LOG =============================
2022-01-01 16:10:07,726:INFO:certbot.renewal:Cert not yet due for renewal
2022-01-01 16:10:07,727:DEBUG:certbot.plugins.selection:Requested authenticator nginx and installer nginx
2022-01-01 16:10:07,727:DEBUG:certbot.plugins.selection:Selecting plugin: * nginx
Description: Nginx Web Server plugin
Interfaces: IAuthenticator, IInstaller, IPlugin
Entry point: nginx = certbot_nginx.configurator:NginxConfigurator
...........

2022-01-01 16:46:00,566:DEBUG:certbot.main:certbot version: 0.31.0
2022-01-01 16:46:00,567:DEBUG:certbot.main:Arguments: ['--apache']
2022-01-01 16:46:00,567:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#nginx,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2022-01-01 16:46:00,584:DEBUG:certbot.log:Root logging level set at 20
2022-01-01 16:46:00,584:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2022-01-01 16:46:00,588:DEBUG:certbot.plugins.selection:Requested authenticator apache and installer apache
2022-01-01 16:46:00,588:DEBUG:certbot.plugins.selection:No candidate plugin

My web server is (include version): Debian 10 Buster

The operating system my web server runs on is (include version): Debian 10 Buster

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes, sudo

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): NO, only ssh

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 0.31.0

I see two different IPs:

Name:    valoliitto.fi
Address: 34.102.136.180
1 Like

Certificates can be used by all services on the server.
Please show the output of:
certbot certificates

1 Like

THIS IS THE ANSWER ON 81.19.123.73 (backup server)


Found the following certs:
Certificate Name: häh.fi
Domains: häh.fi
Expiry Date: 2022-03-26 23:27:05+00:00 (VALID: 76 days)
Certificate Path: /etc/letsencrypt/live/xn--hh-via.fi/fullchain.pem
Private Key Path: /etc/letsencrypt/live/xn--hh-via.fi/privkey.pem


these are the ones I mentioned the previous admin installed before me.

THIS IS THE ANSWER ON 81.19.123.76 valoliitto.fi domain server


No certs found.


The IP 81.19.123.76 is correct. For some reason the propagation was "odd" and part went to the one you mention.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.