Can't get letsencrypt to install error code 1


#1

I’m trying to install Letsencrypt on a DigitalOcean Ubuntu 14.04 instance. Everything looks fine when I run the letsencrypt-auto command but then I get:

Command “/root/.local/share/letsencrypt/bin/python2.7 -c “import setuptools, tokenize;file=’/tmp/pip-build-d2GoNN/cryptography/setup.py’;exec(compile(getattr(tokenize, ‘open’, open)(file).read().replace(’\r\n’, ‘\n’), file, ‘exec’))” install --record /tmp/pip-vmLs2W-record/install-record.txt --single-version-externally-managed --compile --install-headers /root/.local/share/letsencrypt/include/site/python2.7/cryptography” failed with error code 1 in /tmp/pip-build-d2GoNN/cryptography

Any suggestions?


Certbot fails in CentOS version 7
#2

This could be memory issue, or related to the pip install itself on DigitalOcean … does this thread help ?


#3

If that doesn’t work there is another similar DigitalOcean issue ( and solution ) in this thread


#4

I tried both the threads, stopped any mysql process too, and make sure no other processes is running in the server, and still it does not work.


#5

Just for clarity, the above post relates to

I suggested this thread might have a possible fix.

:smiley: