Can't get a certificate with certbot for www subdomain


#1

Hi,

I ran the certbot certonly to issue a new certificate and it told me that it could not find the A record for my domain www.zearon.com. But when i did it for zearon.com, it’s OK. However, I need the certificate working for other subdomains too, like home.zearon.com, and etc, which all ended with the error:

ssl# ./certbot-auto certonly --standalone -d zearon.com -d www.zearon.com
Saving debug log to /var/log/letsencrypt/letsencrypt.log


You have an existing certificate that contains a portion of the domains you
requested (ref: /etc/letsencrypt/renewal/zearon.com.conf)

It contains these names: zearon.com

You requested these names for the new certificate: zearon.com, www.zearon.com.

Do you want to expand and replace this existing certificate with the new
certificate?

(E)xpand/©ancel: e
Renewing an existing certificate
Performing the following challenges:
tls-sni-01 challenge for zearon.com
tls-sni-01 challenge for www.zearon.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.zearon.com (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: DNS problem: query timed out looking up A for www.zearon.com

IMPORTANT NOTES:

  • The following errors were reported by the server:

Domain: www.zearon.com
Type: connection
Detail: DNS problem: query timed out looking up A for
www.zearon.com

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you’re using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

I tried several times later and it always gave the the same error.
My server is hosted on a VPS with the Demain 7 OS, and the domain name zearon.com is registered with Godaddy, but I change the NS servers to a/b/c.dnspod.com. I can get the A record of www.zearon.com and home.zearon.com on my computer with

ssl# dig @8.8.8.8 www.zearon.com

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> @8.8.8.8 www.zearon.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8981
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.zearon.com. IN A

;; ANSWER SECTION:
www.zearon.com. 3571 IN A 209.141.50.18

;; Query time: 34 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sat Mar 11 12:59:03 2017
;; MSG SIZE rcvd: 48

Would you guys help me with this problem?


#2

Your DNS provider is unreliable, at least from the United States.

I just gave it a try: Of their many IP addresses, 3 responded to my first query, 1 responded after a couple retries, and 6 did not respond at all.

DNSViz had similar results:

http://dnsviz.net/d/zearon.com/dnssec/
http://dnsviz.net/d/www.zearon.com/dnssec/

I take it most or all of DNSPod’s servers are located in China, on the other side of the Great Firewall?

It’s actually not the first time DNSPod has come up on this forum:

https://community.letsencrypt.org/search?q=dnspod

I figure your options are to use a DNS provider that works more reliably both inside and outside China, or to keep retrying the Certbot commands until it works.

Edit: From my viewpoint, 4 of their IP addresses are probably in Hong Kong, and the rest are most likely elsewhere in China.


#3

I changed my DNS server and it works now!

Thank you so much!!!


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.