Cant generate ssl

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: lju65i.online

I ran this command:sudo /usr/local/bin/certbot-auto certonly --dry-run --agree-tos --email admin@lju65i.online --webroot -w /var/lib/letsencrypt/ -d lju65i.online -d www.lju65i.online

It produced this output:Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for lju65i.online
http-01 challenge for www.lju65i.online
Using the webroot path /var/lib/letsencrypt for all unmatched domains.
Waiting for verification...
Challenge failed for domain lju65i.online
Challenge failed for domain www.lju65i.online
http-01 challenge for lju65i.online
http-01 challenge for www.lju65i.online
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

My web server is (include version): centos 8

The operating system my web server runs on is (include version): centos 8

My hosting provider, if applicable, is: digitalocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

both DNS are properly point to my server

I'm pretty sure that path is not the webroot of your site.

hi this supposed to which path ?

I'm afraid I don't understand the question. The path you're quoting is the path of the certbot-auto script. The path I'm quoting, is the webroot path. These are two very different things.

i follow this tutorial

encounter error when obtaining the certificate

What's the complete output of nginx -T? Please place three backticks (```) above and below the output, so the forum software can format it properly.

hey thanks for the reply I had solved it
because all my www.subomian no dns , so I exclude the those domains.and it works (bow)

Your www subdomain is a CNAME for lju65i.online. It looks like there isn't any DNS issue for your www subdomain. Also, your hostname lju65i.online without the www subdomain gave a 404 file not found error..

But hey, if you got things working and you're happy, I'm happy :slight_smile:

2 Likes