I cant create ssl certificates

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: lebenmc.de

I ran this command: certbot certonly --nginx -d node4.lebenmc.de

It produced this output: An unexpected error occurred:
The server experienced an internal error :: The service is down for maintenance or had an internal error. Check https://letsencrypt.status.io/ for more details.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): Nginx latest

The operating system my web server runs on is (include version): Ubuntu 22.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

1 Like

Hello @Jauni, welcome to the Let's Encrypt community. :slightly_smiling_face:

Sorry; generally one just has to wait. :frowning:

1 Like

for how long?

I literally used it 5 minutes ago and it worked

That problem was resolved yesterday. Are you getting that error right now?

Does it repeat?

Because there is no current active outage. But maybe yours is the first?

May 16, 2024 22:42 UTC

[Monitoring] We've applied a fix to the elevated rate of 503 responses as of 19:50 UTC, with no 503s served since then. We will continue monitoring through the next periods of high load before marking this incident resolved.

2 Likes

yes i get the same error on 3 different servers
im getting the error right now, but 15 minutes ago it worked
hopefully not it literally worked 15mins ago and its breaking the workflow

Can you post or upload that log file? I need to be away for a bit but those details would be helpful for other volunteers to assess the failure response exactly.

2 Likes

can confirm, I've got the same issue and there also is an active incident on https://letsencrypt.status.io/ aswell

1 Like

Presently here https://letsencrypt.status.io/ I see

2 Likes

ahh i see, how long does it take normally?

The status page is now showing an active incident. That is the place to track the progress

3 Likes

I have the same error as the OP when trying to generate a new certificate.

Tested on a server that is known to be working, i.e nothing has been changed.

Failing on a new setup too.

Nothing showing at https://letsencrypt.status.io, although, it says Active Incident - but no details.

Outages are not common. Reasons are often different.As they know something they will post on that status page

3 Likes

Ha! Someone's just updated the status page.

2 Likes

It really can't be true, I was just generating SSL certificates for my 7 nodes and then in the middle of the 4 node the service outage comes

seeing the same thing here

2024-05-18 19:00:36,198:DEBUG:certbot._internal.log:Exiting abnormally: Traceback (most recent call last): File "/snap/certbot/3700/bin/certbot", line 8, in <module> sys.exit(main()) File "/snap/certbot/3700/lib/python3.8/site-packages/certbot/main.py", line 19, in main return internal_main.main(cli_args) File "/snap/certbot/3700/lib/python3.8/site-packages/certbot/_internal/main.py", line 1894, in main return config.func(config, plugins) File "/snap/certbot/3700/lib/python3.8/site-packages/certbot/_internal/main.py", line 1582, in certonly le_client = _init_le_client(config, auth, installer) File "/snap/certbot/3700/lib/python3.8/site-packages/certbot/_internal/main.py", line 838, in _init_le_client return client.Client(config, acc, authenticator, installer, acme=acme) File "/snap/certbot/3700/lib/python3.8/site-packages/certbot/_internal/client.py", line 297, in __init__ acme = acme_from_config_key(config, self.account.key, self.account.regr) File "/snap/certbot/3700/lib/python3.8/site-packages/certbot/_internal/client.py", line 72, in acme_from_config_key directory = acme_client.ClientV2.get_directory(config.server, net) File "/snap/certbot/3700/lib/python3.8/site-packages/acme/client.py", line 330, in get_directory return messages.Directory.from_json(net.get(url).json()) File "/snap/certbot/3700/lib/python3.8/site-packages/acme/client.py", line 704, in get return self._check_response( File "/snap/certbot/3700/lib/python3.8/site-packages/acme/client.py", line 602, in _check_response raise messages.Error.from_json(jobj) acme.messages.Error: urn:acme:error:serverInternal :: The service is down for maintenance or had an internal error. Check https://letsencrypt.status.io/ for more details. 2024-05-18 19:00:36,199:ERROR:certbot._internal.log:An unexpected error occurred: 2024-05-18 19:00:36,199:ERROR:certbot._internal.log:acme.messages.Error: urn:acme:error:serverInternal :: The service is down for maintenance or had an internal error. Check https://letsencrypt.status.io/ for more details.

its working again