Can't find the rewrite rules, having problems with the certificates now

#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
neiblung.com
I ran this command:
letsencrypt

It produced this output:

  • The following errors were reported by the server:

Domain: neiblung.com

Type: unauthorized

Detail: Invalid response from

http://neiblung.com/.well-known/acme-challenge/PQykn8PrEXBTCsLfk4ynOCa5iZ0drcM_Vc_qRC3bC9k

[34.204.137.59]: "<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML

2.0//EN">\n<html><head>\n<title>400 Bad

Request</title>\n</head><body>\n<h1>Bad Request</h1"

To fix these errors, please make sure that your domain name was

entered correctly and the DNS A/AAAA record(s) for that domain

contain(s) the right IP address.

My web server is (include version):
apache 2.4.18
The operating system my web server runs on is (include version):
ubuntu 16.04
My hosting provider, if applicable, is:
amazon aws

I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

The machine that I am working on has many virtual servers of which this (neiblung.com) is one. When updating the certificate of another domain successfully, I accidentally did a rewrite of http to https, which seemed to affect all domains on the machine.

In the process of trying to fix the problem, and fixing the certificates I can’t seem to update the certificate of neiblung.com.

What would help me would be to turn off the rewrite which I can’t find the in the apache config files (under /etc/apache2/sites-enabled), nor in any of the .htaccess files.

1 Like
#2

Hi,

It seems that you’ve configtured the port 80 to https, (and port 443 to https too)

Please check your apache file… and see the port issue.

Thank you

1 Like
closed #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.