Can't find certbot-auto


#1

Hi guys I’m a novice when it comes to using this and I just followed this tutorial https://www.onepagezen.com/ssl-certificate-setup-for-wordpress-on-google-cloud-bitnami/

As you can see, it says there that it auto-renews but today one of my websites did not renew and it’s ssl certificates expired. now to prevent my other websites’ ssl from expiring I will just do it manually. However, I can’t find my certbot-auto file to do the command. The /tmp/certbot folder is gone for some reason and the /etc/letsencrypt does not have certbot-auto file.

Oddly enough, my other websites, still does have the /tmp/certbot folder and 1 has the certbot-auto file inside /etc/letsencrypt

My domain is: https://www.primeglobalbrand.com/

I ran this command: cd /etc/letsencrypt/ && ./certbot-auto renew && /opt/bitnami/ctlscript.sh restart

also this

cd /tmp/certbot/
./certbot-auto renew --dry-run

It produced this output: -bash: ./certbot-auto: No such file or directory

My web server is (include version): i use google cloud platform compute engine

The operating system my web server runs on is (include version): Debian 4.9.110-3+deb9u5 (2018-09-30) x86_64

My hosting provider, if applicable, is: google cloud platform

I can login to a root shell on my machine (yes or no, or I don’t know): yes that’s where i type the commands

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

also i know the basics only so i apologize if i dont understand a lot of the stuff. the documentation also confused me and i just followed the onepagezen tutorial.


#2

Hi,

What directory did you install certbot-auto?
Have you tried to ls the folder and see if there’s any file left?

Also, if you are using Bitnami for GCP, there’s a tutorial written by bitnami to help you request certificate using lego. https://docs.bitnami.com/google/how-to/generate-install-lets-encrypt-ssl/

Thank you


#3

I believe certbot-auto was in the /tmp/certbot folder before but now it’s gone

for the lego tutorial, will this work even if i have an ssl still? because my other websites still have ssl and havent expired yet


#4

Hi @mktg12,

It is a bad idea to left software in /tmp folder, I suppose your O.S. has some cron job, systemd timer to clean /tmp folder periodically, or maybe another process removed it, anyway, you should install certbot-auto again in another folder and modify your cron job.

The author of that guide recommends to follow this guide: https://www.onepagezen.com/free-ssl-certificate-wordpress-google-cloud-bitnami/

Good luck,
sahsanu


#5

so do i repeat the process? how do renew the certificate before it expires? i reinstall certbot and then just type the renew command?

also, does reinstalling certbot again mess up my current certificate?


#6

Hi,

Since you have already got things working before with certbot-auto, you could simply reinstall the certbot-auto again (but not under /tmp/) and run ./certbot-auto renew when it’s done.

You should be able to use ./certbot-auto renew to renew the certificate since the configuration files under /etc/letsencrypt/ normally are not deleted even though certbot-auto installed under /tmp/ is removed.

I don’t think so, but just in case, please make a copy to /etc/letsencrypt/ directory before you reinstall certbot-auto.

Thank you


#7

thank you it works! however, what about the website that has the ssl expired. i installed certbot and i executed ./certbot-auto renew . i checked the expiry date and it changed so my certificate was “renewed” on th eexpired ssl website but it still gives me an http connection. how do i put it back to https? i assume the website still thinks i havent renewed it despite certbot renewing it.


#8

Hi,

Which domain is that?

Thank you


#9

the website is www.gamepow.co

thank you


#10

Hi,

Could you please locate that domain’s apache / nginx SSL virtual host configuration file and check if the SSLcertificate path is pointed to the correct folder under letsencrypt certificate folders?

Thank you


#11

is this nano /opt/bitnami/apache2/conf/bitnami/bitnami.conf it?

i put this code months ago
SSLCertificateFile “/etc/letsencrypt/live/gamepow.co/cert.pem”
SSLCertificateKeyFile “/etc/letsencrypt/live/gamepow.co/privkey.pem”
SSLCertificateChainFile “/etc/letsencrypt/live/gamepow.co/chain.pem”

and this

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/(.*) https://%{SERVER_NAME}/$1 [R,L]

i got this from this tutorial https://www.onepagezen.com/ssl-certificate-setup-for-wordpress-on-google-cloud-bitnami/

i restarted my apache and it says that my certificate is now valid if you click the “not secure” but it still shows not secure.


#12

I can’t see any problem with your site, it is loading the new cert and it is secured:

imagen


#13

oh for some reason it didnt show up properly on incognito. anyway, i loaded it up on the non incognito and it worked! thank you guys so much! i learned a lot!

thank you as well stevenzhu!

keep up the good work!


#14

Yeah… It works after server restart.

That might be a browser caching issue…
It’s working on my end too…

Thank you