Can't authenticate with dynv6.net address

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: americanpenguin.dynv6.net

I ran this command: certbot certonly --standalone

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Please enter the domain name(s) you would like on your certificate (comma and/or
space separated) (Enter 'c' to cancel): americanpenguin.dynv6.net
Requesting a certificate for americanpenguin.dynv6.net

Certbot failed to authenticate some domains (authenticator: standalone). The Certificate Authority reported these problems:
Domain: americanpenguin.dynv6.net
Type: connection
Detail: 2605:59c8:251b:a310:6445:5fff:fe86:ff82: Fetching http://americanpenguin.dynv6.net/.well-known/acme-challenge/oYz9l28D5rb7KydLxWchvggm5LjZDGuw6BeXEyleGIY: Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to download the challenge files from the temporary standalone webserver started by Certbot on port 80. Ensure that the listed domains point to this machine and that it can accept inbound connections from the internet.

Some challenges have failed.

My web server is (include version): CUPS Latest

The operating system my web server runs on is (include version): Fedora 36

My hosting provider, if applicable, is: Starlink

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 2.1.0

Other information: I'm trying to use IPv6 because I have a real IPv6 address; IPv4 is NAT'ed. I have a TCP dump and I can see it's successfully connecting to the temporary web server over 80 on IPv6 and for some reason, IPv4 is showing traffic. Disabled IPv4 and it shows the same error. I just want a cert so I can print from anywhere.

Hi @Jasonbrianhall, and welcome to the LE community forum :slight_smile:

LE is trying to use the IPv6 address.
But, as the error message shows, it is unable to reach your web service.
Are there any firewalls that need to be opened for port 80 [via IPv6]?
[i.e. Does your HTTP site work via IPv6 over the Internet?]

5 Likes

btw ipv6 having no NAT does not mean there will be no firewall:
ipv6 for starlink is new thing so I'm not sure their router config firewall for them.

4 Likes

I can see the web traffic so I know it's hitting port 80; I also have expressVPN and could hit my cups server on 631 and I ran a web server on 80, 443, and 8080 and they all worked; so pretty sure it's not a firewall issue.

It is outbound HTTP traffic that is shown on the image, not inbound.

5 Likes

Yes, that seems to be the problem; it's blocked at the ISP level.