Unable to create a certificate IPv6 only

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: next.poessibility.dynv6.net

I ran this command: certbot --apache

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated) (Enter 'c' to cancel): next.poessibility.dynv6.net
Requesting a certificate for next.poessibility.dynv6.net
Performing the following challenges:
http-01 challenge for next.poessibility.dynv6.net
Waiting for verification...
Challenge failed for domain next.poessibility.dynv6.net
http-01 challenge for next.poessibility.dynv6.net
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: next.poessibility.dynv6.net
    Type: connection
    Detail: 2a00:6020:4199:4200:210f:76cb:9d86:6ad3: Fetching
    http://next.poessibility.dynv6.net/.well-known/acme-challenge/vIOP8M_FBCS3gi25GV-YOS3n2fc1MiWSYW99xDvBkr8:
    Error getting validation data

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you're using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): apache2

The operating system my web server runs on is (include version): Raspbian GNU/Linux 11 (bullseye)

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 1.12.0

There is an working AAA-Record on dynv6.com and a port-forwarding for 80 and 443 configured in FritzBox. The Webserver Test-Page is reacheable from outside, even the testwise created .well-known directory.
I also tried to get a certificate with a new nextcloud-installation - didn't work.
Any idea would be highly appreciated!
Thanks a lot!
Johannes

You don't seem to have a proper VirtualHost setup for HTTP (port 80). The certbot apache plug-in looks for that to do the Challenge. If successful, it uses that VirtualHost to configure another VirtualHost for HTTPS (port 443).

Can you show result of this

apachectl -t -D DUMP_VHOSTS
5 Likes

Hi @poessibility, and welcome to the LE community forum :slight_smile:

It seems that you were able to obtain a certificate:

Maybe you could explain what went wrong and how you fixed it - to help any future readers :slight_smile:

5 Likes

You're right, it finally worked.
To be honest, I don't know exactly where the error was. I renewed the port forwarding of the FritzBox to port 80 exactly as it was before and then booted the box.
After that it worked. So I suspect - without being able to say for sure - that there was a problem with the firewall on the FritzBox.
Thanks for the help anyway! You guys are great!

2 Likes

I've found the problem!:

FritzBoxes are really consumer devices with, IMO, lots and lots of bugs. I can't even modify my portmaps using Chrome, need to start Firefox, if I'm lucky.

Sometimes a factory reset is the only way to fix that piece of ...

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.