Cannot renew SSL

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: crexspace.com

I ran this command: certbot renew from root

It produced this output:Saving debug log to /var/log/letsencrypt/letsencrypt.log


No renewals were attempted.


My web server is (include version): nginx/1.12.2

The operating system my web server runs on is (include version): mac os 10.13.6

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): termius

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): don’t know

Please show:
certbot certificates

It says no certificates found!

Then you should be using an action other than “renew”.
[there is no cert to “renew”]

I do see that you have a cert that will be expiring soon.
Perhaps multiple acme clients were installed…?
Please show:
grep -ERi 'ssl_cert|crexspace.com|listen|virtual|server_name' /etc/nginx/

Ok, how sorry I am not familiar with this at all. And I do have a certificate from letsencrypt running it expires on the 7 november.

  1. Login to the server.
    [usually some sort of SSH client]

  2. copy/paste following command and press enter
    grep -ERi 'ssl_cert|crexspace.com|listen|virtual|server_name' /etc/nginx/
    if nothing shows, try with sudo
    sudo grep -ERi 'ssl_cert|crexspace.com|listen|virtual|server_name' /etc/nginx/

  3. copy/paste the response from command in your reply here.

We’re looking for which cert is now in use and the full file path to it - which should indicate which ACME client was used to obtain the cert and thus point us in a direction to properly renew it.

It says no such file or directory…

Ok, I tried both on termius the ssh client. same response

]$ sudo grep -ERi 'ssl_cert|[crexspace.com](http://crexspace.com)|listen|virtual|server_name' /etc/nginx/
grep: /etc/nginx/: No such file or directory
]$ sudo grep -ERi 'ssl_cert|[crexspace.com](http://crexspace.com)|listen|virtual|server_name' /etc/nginx/
grep: /etc/nginx/: No such file or directory
/etc/nginx/: No such file or directory
/etc/nginx/: No such file or directory

/etc/nginx/:no such file or directroy

It is running NGINX from somewhere…

curl -Iki https://crexspace.com/
HTTP/1.1 200 OK
Server: nginx/1.12.2
Date: Mon, 04 Nov 2019 13:18:23 GMT
Content-Type: text/html; charset=utf-8
Content-Length: 50979
Connection: keep-alive
X-Powered-By: Next.js 5.0.0
ETag: "c723-aRhCNVn3C/Ky9/63TGWCNBYGsUs"
Vary: Accept-Encoding

Please show:
which nginx

If that shows it, try:
nginx -T | grep -Ei 'ssl_cert|crexspace|listen|virtual|server_name'

Ground Control to Major Tom

Your circuit’s dead, there’s something wrong

Shows below…

Screen Shot 2019-11-04 at 3.38.40 PM.png

Great, ground control, I have no idea what that might be….as I said I am not familiar with this. I was told to just write certbot renew from the developers and it would renew.

But certbot has no cert to renew…

Try
find / -name nginx
and
nginx -T | grep -Ei 'ssl_cert|crexspace|listen|virtual|server_name'

and to be sure we are on the correct box:
show output of:
curl ipconfig.me

which should match IP:
nslookup crexspace.com

Hi @Crex

checking your domain there is an older check, created this morning. And two older certificates - https://check-your-website.server-daten.de/?q=crexspace.com#ct-logs

Issuer not before not after Domain names LE-Duplicate next LE
Amazon 2019-11-03 2020-12-03 www.crexspace.com - 1 entries
Let's Encrypt Authority X3 2019-08-09 2019-11-07 www.crexspace.com - 1 entries
Let's Encrypt Authority X3 2019-08-09 2019-11-07 crexspace.com, www.crexspace.com - 2 entries

How did you create these certificates?

The first with two domain names is good.

Do that again.

You have 3 days to figure this out…
I’m thinking you are connected to the wrong server.

I tried that nothing
it says bash: nginx: comand not found

are you logged in a root user?
please also show output of:
curl ifconfig.me