Cannot renew certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:
sudo certbot-auto renew --webroot -w /var/www/nextcloud
It produced this output:
root@nextcloud:/var/www/nextcloud# sudo certbot-auto renew --webroot -w /var/www/nextcloud
Saving debug log to /var/log/letsencrypt/letsencrypt.log

Processing /etc/letsencrypt/renewal/

Cert is due for renewal, auto-renewing…
Plugins selected: Authenticator webroot, Installer None
Running pre-hook command: service apache2 stop
Renewing an existing certificate
Performing the following challenges:
http-01 challenge for
Using the webroot path /var/www/nextcloud for all unmatched domains.
Waiting for verification…
Challenge failed for domain
http-01 challenge for
Cleaning up challenges
Attempting to renew cert ( from /etc/letsencrypt/renewal/ produced an unexpected error: Some challenges have failed… Skipping.
All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)

All renewal attempts failed. The following certs could not be renewed:
/etc/letsencrypt/live/ (failure)

Running post-hook command: service apache2 start
1 renew failure(s), 0 parse failure(s)


  • The following errors were reported by the server:

    Type: connection
    Detail: Fetching
    Timeout during connect (likely firewall problem)

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version):
The operating system my web server runs on is (include version):
Ubuntu 18.04.1 LTS

My hosting provider, if applicable, is:
I can login to a root shell on my machine (yes or no, or I don’t know):
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
certbot 0.31.0
certbot 0.34.2

Hi @jiju

your http port 80 isn't visible, only timeouts ( ):

Domainname Http-Status redirect Sec. G
• -14 10.027 T
Timeout - The operation has timed out
• 302 1.700 N
Certificate error: RemoteCertificateChainErrors
• 200 1.324 N
Certificate error: RemoteCertificateChainErrors
• -14 10.030 T
Timeout - The operation has timed out
Visible Content:

You need an open and answering port 80, that port may redirect to https.

You have a lot of older certificates:

CRT-Id Issuer not before not after Domain names LE-Duplicate next LE
1226812583 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2019-02-22 16:50:29 2019-05-23 15:50:29
1 entries
1054760227 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2018-12-24 15:59:55 2019-03-24 15:59:55
1 entries
881217964 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2018-10-22 04:22:28 2019-01-20 05:22:28
1 entries
790760107 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2018-08-22 22:16:44 2018-11-20 23:16:44
1 entries
571798046 CN=Let's Encrypt Authority X3, O=Let's Encrypt, C=US 2018-06-23 04:12:16 2018-09-21 04:12:16
1 entries

Looks like you have used tls-sni-01 validation via port 443, that's not longer supported, ended ~2019-03-15.

So this may be your first certificate using http-01 validation.

Dear juergen,
Thank you, As you explained, my https was redirected to https and I was trying to renew certificates through 443, but its got failed.
I tried different methods and stopping http redirection for checking .well-known/acme-challenge/1234 file access, its got access from url but o curl its shows permanently redirect 301
so i hope the same issue stopping certificate renewal, please advice

I don't see a redirect http -> https. I see a http timeout.

So http-01 validation can't work.

A correct redirect http -> https isn't a problem that stops certificate renewal. Letsencrypt follows these redirects. But the first check goes to port 80, there must be an answer.

please check it now

Note: it was working without any problem but suddenly why services has stopped and certificate renewal got problems, is because of any updations?

You can use the online tool to check such things.

Checked the subdirectories + file -

the same image: http doesn't answer.

Domainname Http-Status redirect Sec. G
• -14 10.027 T
Timeout - The operation has timed out
• 200 1.180 N
Certificate error: RemoteCertificateChainErrors
• -14 10.027 T
Timeout - The operation has timed out
Visible Content:

As written: You may have used tls-sni-01 validation, that's not longer supported.

here on my cloud everything redirect to https but on curl it shows 301
Do you have any idea why its not resolving and showing http timeout.

I tried all possibilities none of them works, is there any way to renew our licences

That may be your internal access. But external - I see only timeouts.

Wrong firewall, wrong router port forwarding. Or it is a home server and your ISP blocks port 80.

You can use dns-01 validation and --manual, that should always work. But you may not automate that, so you have to do that every 60 - 85 day.

Or use tls-alpn-01 validation via port 443. But certbot doesn't support that, does.


Ok I will follow it for time being and then resolves the http problem

1 Like

I did the above method though sudo certbot run -a webroot -i apache -w /var/www/nextcloud -d
You can use dns-01 validation and --manual

but its still not reflected

That's the http-01 challenge, not the dns-01 challenge. But http-01 requires an open port 80, your port 80 is closed.

If you want to use dns-01, use something like

sudo certbot --manual --preferred-challenges dns -d -i apache

then you have to create a TXT entry in your dns configuration with a special value.

Perhaps add --debug-challenges, then Certbot waits, then recheck the domain to check, if you have created the correct TXT entry.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.