Cannot renew certificate


#1

Hello, I have a strange problem with renewing my certificate. The domain is kupiopravu.ru, certificate is valid till 07 May.

Today (05 May) I run the renewal process with --keep-until-expiring option and see message “Certificate not yet due for renewal”. I run command several times without result.

After that I delete folders with domain name in /etc/letsencrypr/live, /etc/letsencrypr/archive and config files. Run command again, and see message “Too many certificates already issued”.

Now I have expiring certificate on my server and cannot issue new certificate. What can I do?


#2

Did you keep a backup of the files you deleted ?

What I’d guess happened was that you requested and got a renewal which was stored locally in the live folder. The script checked this every time - hence saying that the “Certificate not yet due for renewal” I’d suspect that certificate wasn’t uploaded into your webserver though ( apache / nginx needed to be restarted) so you thought it still deeded renewing. If you have a backup of the files you deleted I’m sure you will find the certificate there. If not, let us know and we’ll provide another way of getting the cert.


#3

Thank you for answer.

Unfortunatelly, I have no backup of deleted files.
Please help me if you can.


#4

As long as you have your private key, you can get your issued certs from the web, and use those.

You can see your certs issued at https://crt.sh/?q=+kupiopravu.ru

following the link on the most recent of these is https://crt.sh/?id=18137978

Clicking on the “certificate” link will give you the certificate - https://crt.sh/?d=18137978

which you can then use, along with your private key, on your server. You will need to load it into the correct place on your server, then reload your apache / nginx

P.S. it’s always worth taking a backup before you delete things :wink:


#5

Thank you in advance, it works!!!

Yes, backups are important.
There are two kinds of people in the World - those who do backups and those who will do …


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.