Cannot issue certificates because http acme-challenge fails

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: htttp://dev.pullscription.com

I ran this command: sudo certbot

It produced this output:
sudo certbot -v
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx

Which names would you like to activate HTTPS for?
We recommend selecting either all domains, or all domains in a VirtualHost/server block.


1: dev.admin.pullscription.com
2: dev.pullscription.com
3: dev.tools.pullscription.com
4: dev.web.pullscription.com


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter 'c' to cancel):
Requesting a certificate for dev.admin.pullscription.com and 3 more domains
Performing the following challenges:
http-01 challenge for dev.admin.pullscription.com
http-01 challenge for dev.pullscription.com
http-01 challenge for dev.tools.pullscription.com
http-01 challenge for dev.web.pullscription.com
Waiting for verification...
Challenge failed for domain dev.admin.pullscription.com
Challenge failed for domain dev.pullscription.com
Challenge failed for domain dev.tools.pullscription.com
Challenge failed for domain dev.web.pullscription.com
http-01 challenge for dev.admin.pullscription.com
http-01 challenge for dev.pullscription.com
http-01 challenge for dev.tools.pullscription.com
http-01 challenge for dev.web.pullscription.com

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Domain: dev.admin.pullscription.com
Type: unauthorized
Detail: 2600:3c01::f03c:93ff:fe92:f31e: Invalid response from http://dev.admin.pullscription.com/.well-known/acme-challenge/Wp7FDRcrPWcnUYubv1zst7Wqu4EewCcm0fknDZ6uU8I: 404

Domain: dev.pullscription.com
Type: unauthorized
Detail: 2600:3c01::f03c:93ff:fe92:f31e: Invalid response from http://dev.pullscription.com/.well-known/acme-challenge/nRKW0zPmgH0CH-tYOwIrR8BMJA60mrydK3vjgz7iXBs: 404

Domain: dev.tools.pullscription.com
Type: unauthorized
Detail: 2600:3c01::f03c:93ff:fe92:f31e: Invalid response from http://dev.tools.pullscription.com/.well-known/acme-challenge/StngWbd2i2ZBT5HNiwQ8lh3VxbFMrp9HOf3XhdAAFGg: 404

Domain: dev.web.pullscription.com
Type: unauthorized
Detail: 2600:3c01::f03c:93ff:fe92:f31e: Invalid response from http://dev.web.pullscription.com/.well-known/acme-challenge/n3B_-zCwkiDL26YRJVnuL8Q7SKGXGfGXqg20_WTXiZ8: 404

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx server and that it is accessible from the internet.

Cleaning up challenges
Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version): nginx 1.24

The operating system my web server runs on is (include version): Debian 12.1

My hosting provider, if applicable, is: Linode

I can login to a root shell on my machine (yes or no, or I don't know): No, but only because I disabled root login

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 2.1.0

I've added:

location /.well-known/acme-challenge/ {
root /var/www/certbot;
}

As recommended by others but that did nothing. I have confirmed that manually I can add the .well-known/acme-challenge/ manually as shown here:

http://dev.pullscription.com/.well-known/acme-challenge/test

Is that IPv6 address pointing to your webserver?

If not, replace it with the appropriate one. If yes, check that your webserver is listening on IPv6 for the same virtualhosts it listens IPv4.

5 Likes


Yes it is.

Listening on IPv6 did it! You are a miracle worker, thank you :pray:t3:

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.