Cannot install Certbot on Debian

My web server is (include version):
Dedicated server running Debian 9, Nginx

Hi there. I didn't answer all the questions because not suitable.
I just upgraded from Debian 7 to Debian 9. Now I want to install Certbot via Snapd (as advised).

apt install snapd
snap install core
Oct  5 13:26:54 reisio systemd[1]: Mounting Mount unit for core...
Oct  5 13:26:54 reisio systemd[1]: Couldn't stat device /dev/pts/ptmx
Oct  5 13:26:54 reisio systemd[1]: snap-core-11743.mount: Mount process exited, code=exited status=32
Oct  5 13:26:54 reisio systemd[1]: Failed to mount Mount unit for core.
Oct  5 13:26:54 reisio systemd[1]: snap-core-11743.mount: Unit entered failed state.
Oct  5 13:26:54 reisio /usr/lib/snapd/snapd[18088]: task.go:303: DEBUG: 2021-10-05T13:26:54+02:00 ERROR [start snap-core-11743.mount] failed with exit status 1: Job for snap-core-11743.mount failed.#012See "s
ystemctl status snap-core-11743.mount" and "journalctl -xe" for details.

It seems there is on my system a /dev/ptmx device but no /dev/pts/ptmx device. So snapd cannot install core nor certbot.

Has anyone encountered this issue?
Thanks in advanced,


1 Like

Hi @Aquel welcome to the LE community forum :slight_smile:

apt update
apt install snap

Shows any update?

Thanks, no, there is no update.

1 Like

No updates at all (to anything)?

Did the upgrade go smoothly?

No upgrade at all, nor dist-upgrade.
The upgrade went pretty fine. Some issues with some PHP packages. But no problem for reboot from 7 to 8 and from 8 to 9.

1 Like

I can't advise on how that can even be fixed.
I'd say, in the meantime, try using another ACME client. Like:
[note: it defaults to ZeroSSL, put can be changed via added parameter]

1 Like

I did install certbot via pip in the meantime but I'd love to find what's wrong. Thanks anyways :slight_smile:

1 Like

Seems to be due to CONFIG_DEVPTS_MULTIPLE_INSTANCES missing from your kernel. Are you running the default kernel? Maybe you can upgrade it? E.g., by using stretch-backports or something? Note that I'm not even sure if the kernel in stretch-backports actually has CONFIG_DEVPTS_MULTIPLE_INSTANCES enabled..


Hello @Osiris thanks a lot, I think you point the right direction. I'll dig into this. Thanks


Not the answer you were probably looking for, but I recently solved my problems by updating from Stretch, to Buster, and then to Bullseye.

Bullseye has in its repos a version of certbot that's new enough to support the switch to use --preferred-chain "ISRG Root X1"

Which is really quite useful to have right about now.

Doing it this way means you don't need to faff around with snap, which is a canonical/ubuntu thing, on a Debian system.

This isn't the only solution I'm sure there are many others, but it's the one that worked for me.

1 Like

Thanks @PhilV I am upgrading slowly from Debian 7 to 10 anyways. We'll see then.
Thanks again

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.