Cannot get my cert renewed on centos 6.7 [solved]


#1

Ive got a cert that expires in a few days on a centos and I cant seem to get it renewed…
when I run
./letsencrypt-auto --renew certonly -d monsterjam.org

it gives me the curses menu and asks If I want to use
1 Apache Web Server - Alpha (apache)
2 Automatically use a temporary webserver (standalone)

no matter which one I choose, it goes through its gyrations and then I get the dreaded…

You’ve asked to renew/replace a seemingly valid certificate with a test certificate (domains: monsterjam.org). We will not do that unless you use the --break-my-certs flag

message…


#2

Are you sure you’re using the real CA server and not the staging server?

Check if there’s a /etc/letsencrypt/cli.ini config file containing the staging server url. You could also try to add --server acme-v01.api.letsencrypt.org/directory when running the letsencrypt-auto command.


Cert renewal error
#3

aha! you were right, it was pointing to the staging server… I pointed it to he server you suggested and it works fine now.

thanks bro! take the rest of the day off… :wink:

-db