The cert did not auto renew by cronjob

Hi, So I have installed letsencrypt SSL cert to my main domain as well as on sub-domains. I have used and it has added the cronjob which runs every 35 min.

I have observed that the cert has not been renewed after 60 days. I read the other community articles but did not find what is causing the problem,

Hosting Provider: Namecheap

Web Server: Apache 2.4.57

Cpanel Version: 102.0 (build 33)

I run command this command to generate letsencrypt RSA 256 cert : --issue -d -w /home/trusrsle/public_html --keylength 2048

The cronjon command:
35 0 * * * "/home/trusrsle/"/ --cron --home "/home/trusrsle/" > /dev/null

I have upgraded the to latest version using --upgrade .

My domain:

The cert will expire on 30 May 2023. Can some please help immediately to fix the problem.

So I ran --list which lists the cert with details such as created on and renew on.
In which the cert details seems to be updated as shown in the image.

Now the issue seems to be not updating in on server or cpanel.


1 Like

@rg305 @barf7709

Please don't haphazardly tag seemingly random persons. They'll see your thread and reply if they want to. And if they don't want to, that's their right. Now you come across very pushy.

Also, you seem to have deleted the majority of the questionnaire. Please answer all the questions to the best of your knowledge, especially the "output" part, because now we're just guessing and/or using a crystal ball. And we all know there ain't no such thing as crystal balls: we need YOU to provide the relevant information.

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):


@Osiris added the information to the description.

I'm still missing a very important answer to one of the questions, so I give up. I'll just add to this thread that the webserver answering on your hostname is not Apache but in fact LiteSpeed, so there's something going on there. But I won't participate in this thread any longer as it requires too much energy for me to have to PULL OUT all the relevant questions, even when asked already.


Your two domain names point to different IP addresses.

You have not described the error you got but different IP addresses will fail (without unusual efforts to share the -w folder)

dig +noall +answer A       261     IN      A

dig +noall +answer A   21      IN      CNAME 21 IN A

Also, as noted by Osiris is your apex domain is using a LiteSpeed server (not Apache as you describe)

Your www domain is connected to some service using a cert from Sectigo which has expired.


Yes, I am using namecheap hosting which provides lightSpeed server. Where can i see the errors?

I was using positive ssl provided by namecheap which is issued by Sectigo. Which is connected to my one of the subdomain.

There seems to be a space missing there.

But, as already mentioned, the two names resolve to different IPs.
You can't obtain a cert for both names from one of those IPs [using HTTP authentication].

And, as your --list shows, the "www" named cert is up-to-date.


The cert is already issued and installed perfectly. It was a typing mistake in the description.

What can be done for ip address?

Let's Encrypt does not support IP addresses in the cert.

If that isn't what you are asking please provide more details


As you can see in the screenshot the certs have been renewed. I want to know when will these renewed cert will replace the previous one. The current cert will be expired on 30 may. Will the renewed one will activated automatically on 1st June?

As soon as you configure your light speed server to use the newer cert that you already have


How can I configure it? I contacted support team but they stated that the configuration is already set and suggested to contact lets-encrypt support team.

I do not use Lightspeed so cannot help you. Sorry


@rg305 @MikeMcQ I want to know precisely when the cert is replaced with a new one. e.g. on my domain, the cert was issued on 1 March and will expire on 30 May. As the GitHub page states the cert will be renewed after 60 days. Will the cert replaced on 61st day or after 30th May?

If your system is configured properly your server should start using the cert as soon as it is renewed


The default is to autorenew on the 61st day.


I have contacted the support team now and then but the issue is not resolved.

I am not sure what to do now to configure cpanel to recognise the renewed cert.