"renew" does not work with apache and multiple domains (and certonly also not)



I start getting frustrated and don’t really know what to do. So far letsencrypt worked since at least December last year, always getting updates to my certs, but it stopped since beginning of this month. I guess it is the client (running it on a debian/raspi, got the latest scripts from github), but not sure.

I’m running an apache server with multiple domains and all I want is to renew them. It failed several times during the last days, I always gave up. I tried again today and now it says

Too many currently pending authorizations.

which is highly frustrating, because I can’t influence this manually.

I call the update with
a) letsencrypt-auto renew
b) letsencrypt-auto certonly --apache -d dom1.com - d www.dom1.com -d dom2.com

it then usually brings up a dialog in which it shows some domains, but not all of them (although all of them are enabled in apache and work well).

My certificates will work for another 25 days. I’m glad to completely dump the current configuration and to reconfigure it all new, but I’m also afraid that this will not work at all.

I’m happy to post any logfile, config etc etc here, but I’m having a problem replacing all my domain names in them. If somebody has similar problems or has solved them, I would be more than happy to get a message.

Thanks a lot for your help!


You should be able to post more links now.

Sounds quite similar to this issue where it turned out that a buggy cronjob ran too frequently, exhausting the rate limits. You’ll probably need to wait a while before you’re able to try this again (that post suggests up to a week).

In the meantime, the following things might help us find the problem:

  • Log files from /var/log/letsencrypt
  • Renewal config files, stored in /etc/letsencrypt/renewal
  • Your apache VirtualHost files (usually in /etc/apache2/sites-enabled/)


First, please make sure you have only one tag per apache config file. The latest letsencrypt client will not work at all if you have more than one per file.