Cannot create certificate, system said account registered

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: /

I ran this command:

certonly --webroot --webroot-path=/var/www/html --email [redacted] --agree-tos --no-eff-email --staging -d -d

It produced this output:

certbot | Requesting a certificate for and
certbot |
certbot | Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
certbot | Domain:
certbot | Type: dns
certbot | Detail: DNS problem: NXDOMAIN looking up A for - check that a DNS record exists for this domain; DNS problem: NXDOMAIN looking up AAAA for - check that a DNS record exists for this domain
certbot |
certbot | Hint: The Certificate Authority failed to download the temporary challenge files created by Certbot. Ensure that the listed domains serve their content from the provided --webroot-path/-w and that files created there can be downloaded from the internet.
certbot |
certbot | Saving debug log to /var/log/letsencrypt/letsencrypt.log
certbot | Some challenges have failed.
certbot | Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.

My web server is (include version):


The operating system my web server runs on is (include version):

Ubuntu 22.04 LTS (GNU/Linux 5.15.0-25-generic x86_64)
Docker version 20.10.17, build 100c701

My hosting provider, if applicable, is:

Domain: Namecheap
Server: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don't know):


I'm using a control panel to manage my site (no, or provide the name and version of the control panel):


The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

certbot 1.28.0
docker image certbot/certbot

Add an A record for your www subdomain in your DigitalOcean DNS interface.


thanks buddy! you solved my problem. :smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.