Cannot create a Let's Encrypt certificate even if the domain is accessible from internet

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
m3.gestennis.com

I ran this command:
sudo certbot --nginx -d m3.gestennis.com

It produced this output:
Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
Domain: m3.gestennis.com
Type: dns
Detail: DNS problem: query timed out looking up A for m3.gestennis.com

My web server is (include version):
nginx 1.18.0

The operating system my web server runs on is (include version):
Ubuntu 20.04 LTS

My hosting provider, if applicable, is:
Serverplan

I can login to a root shell on my machine (yes or no, or I don't know):
yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
I'm using SSH.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):
1.19.0

If I execute this command on my PC (not on my server, which is in a remote server farm):
curl http://m3.gestennis.com
I get the HTML code of my page.
If I use
dig m3.gestennis.com
I receive the correct DNS A record.

Thank you for help!

Hi @altthomas welcome to the LE community forum :slight_smile:

There is a huge DNS problem with your domain.
The "two" authoritative DNS servers resolve to only one IP.
image

And that one IP is mostly unresponsive.

1 Like

Thank you so much.
I solved the problem changing the authorative DNS servers and retrying.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.