Can i use Certbot on windows server 2016

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: hanibaalmailer.ddns.net
it's posible to cmd : ping hanibaalmailer.ddns.net

I ran this command: none

It produced this output: none

My web server is (include version): windows 2016

The operating system my web server runs on is (include version): windows 2016 standart

My hosting provider, if applicable, is: no-ip

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no - using RDP

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): none

i just took cloud and put there no-ip domain name. i want to run there my EMaile Server. it's writen in DELPHI+INDY but i have to create some certificate to connect to this server from my sites.
with https://hanibaalmailer.ddns.net:5555/?MyIp....?Data.....

i tried to bu RapidSSL from No-IP but its take too much time. and its look like there are some problems between On-IP and RapdSSL.

can i use Let'sEncrypt to to this job.
i need file*.cer + file*.key , like -
HanibaalMailer.ddns.net.cer
HanibaalMailer.ddns.net.key

i just install and run Certbot :
i get this
what dose this meen : p0dj7JRuZ-aBI4sOaXabTaMRVJ-TWc21qi_fKDhBfwA: file name or what?

C:\Program Files (x86)\Certbot>certbot certonly --standalone
Saving debug log to C:\Certbot\log\letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Please enter in your domain name(s) (comma and/or space separated) (Enter 'c'
to cancel): hanibaalmailer.ddns.net
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for hanibaalmailer.ddns.net
Waiting for verification...
e[31mChallenge failed for domain hanibaalmailer.ddns.nete[0m
http-01 challenge for hanibaalmailer.ddns.net
Cleaning up challenges
e[31mSome challenges have failed.e[0m
e[1m
IMPORTANT NOTES:
e[0m - The following errors were reported by the server:

Domain: hanibaalmailer.ddns.net
Type: connection
Detail: Fetching
http://hanibaalmailer.ddns.net/.well-known/acme-challenge/p0dj7JRuZ-aBI4sOaXabTaMRVJ-TWc21qi_fKDhBfwA:
Timeout during connect (likely firewall problem)

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
your computer has a publicly routable IP address and that no
firewalls are preventing the server from communicating with the
client. If you're using the webroot plugin, you should also verify
that you are serving files from the webroot path you provided.

yossi

1 Like

There are several Windows ACME clients that can do this job.
See:

1 Like

hi. thanks for the quick response.
i install Certbot and run it and get some *.pem in c:\Certbot\live\hanibaalmaile.ddns.net

image

but i need to create file *.cer + *.key that i can put wher my ServerMailr is.

how can i convert thos files to those i need?
hoe can i check if my HanibaalMailer.ddns.net is noe https?

Yossi

2 Likes

Hi @mazluta

I don't know how that program works.

But it looks that you only have to copy / rename these files:

fullchain.pem -> fullchain.cer
privkey.pem -> privkey.key

Try that.

If that doesn't work, check the documentation to see, which file format is expected. With OpenSsl, converting should be possible.

2 Likes

thanks. i will try it

2 Likes

Please keep in mind that the files in live are LINKS and not normal files!

1 Like

yes. i see it. i will see if it will work

1 Like