Bluehost SSL/DNS Interfering with SSL Installation

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: digitalnomadsage.com

I ran this command: sudo certbot --nginx

It produced this output:

My web server is (include version): NGINX

The operating system my web server runs on is (include version): Ubuntu on VULTR 16.04(?)

My hosting provider, if applicable, is: VULTR

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): I think it’s certbot-auto – version.

My problem is unique because I migrated from Bluehost to VULTR…so my website retained the Bluehost SSL certificate somehow. I’m using Cloudflare so VULTR to cloudflare is insecure/nonexistent bluehost SSL. Cloudflare to internet is Cloudflare SSL.

Certbot says my DNS is not working but my site is up and running fine. So I know DNS works. It won’t accept www.digitalnomadsage.com Any ideas? Thanks!

Hi @jinmanbok

please read your output. There is no named vHost configured, so Certbot can't find the correct vHost.

Knows Cloudflare your new ip?

Or uses Cloudflare your old Bluehost ip address?

If you don't have a working configuration, you shouldn't use Cloudflare, that hides too much.

What's your real ip address?

There is an older check of your domain - https://check-your-website.server-daten.de/?q=digitalnomadsage.com - https had a timeout. Newer check - https worked. But the reason is unclear.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.