AWS bitnami y SSL error chown: cannot dereference

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: poker-craft.com

I ran this command: ```
https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/:

sudo mv /opt/bitnami/apache2/conf/bitnami/certs/server.crt /opt/bitnami/apache2/conf/bitnami/certs/server.crt.old
sudo mv /opt/bitnami/apache2/conf/bitnami/certs/server.key /opt/bitnami/apache2/conf/bitnami/certs/server.key.old
sudo ln -sf /opt/bitnami/letsencrypt/certificates/DOMAIN.key /opt/bitnami/apache2/conf/bitnami/certs/server.key
sudo ln -sf /opt/bitnami/letsencrypt/certificates/DOMAIN.crt /opt/bitnami/apache2/conf/bitnami/certs/server.crt
sudo chown root:root /opt/bitnami/apache2/conf/bitnami/certs/server*
sudo chmod 600 /opt/bitnami/apache2/conf/bitnami/certs/server*


It produced this output: 
chown: cannot dereference '/opt/bitnami/apache2/conf/bitnami/certs/server.crt': No such file or directory
chown: cannot dereference '/opt/bitnami/apache2/conf/bitnami/certs/server.crt.old': No such file or directory
chown: cannot dereference '/opt/bitnami/apache2/conf/bitnami/certs/server.key': No such file or directory
chown: cannot dereference '/opt/bitnami/apache2/conf/bitnami/certs/server.key.old': No such file or directory

My web server is (include version): AWS

The operating system my web server runs on is (include version): W10

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of `certbot --version` or `certbot-auto --version` if you're using Certbot): no

Welcome to the community @Alakomax

The good news is I see you successfully created a Let's Encrypt cert.

I do not know bitnami very well but it needs different methods depending on your system. Have you seen this article? Does it help your problem?
https://docs.bitnami.com/aws/how-to/understand-bncert/

2 Likes

I don't know what to do, I'm new to the area, the page is stopped, and I don't know how to continue

There are some volunteers here who know bitnami so maybe one will help.

Usually when we see people with bitnami problems they cannot get their Let's Encrypt cert. You got one so you are just dealing with a bitnami config / setup problem. You could try posting at the bitnami forum too.

2 Likes

There are? As far as I know, everybody here avoids Bitnami as the plague.

4 Likes

@9peppe seems to have some experience :slight_smile:

And, I did say maybe

4 Likes

In your second sentence :wink:

3 Likes

not really, but...

can't really mean many things.

I'd like to know what OP is trying to do. They are probably copying the commands that apply to some other configuration.

2 Likes

Thanks to all, I was able to resolve the conflict, I was not following the steps in the commands correctly, the permissions could be created, but apparently it is still necessary to install the SSL plugins in wordpress for it to be activated. Thanks

2 Likes

I don't think you need those plugins. Also, it should've just worked automatically.

2 Likes

I get a valid certificate but the security padlock shows that the site is not secure :roll_eyes: https://poker-craft.com

Try restarting your browser. Your cert looks good to me:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.