Install lets encrypt error on bintami terminal


#1

Hi there,

Im using AWS bitnami wordpress. Complete novice at this so please go easy.

We had the Lets encrypt set up for 90 days. It expired and now I’m trying to reinstall it again following this guide:

https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/

I get to the third line and it comes up with error:

No such file or directory. Error is not recoverable. Exiting now.

Please advise. Thanks

My domain is: great-teams-academy.com

I ran this command:
cd /tmp
curl -s https://api.github.com/repos/xenolf/lego/releases/latest | grep browser_download_url | grep linux_amd64 | cut -d ‘"’ -f 4 | wget -i -
tar xf lego_vX.Y.Z_linux_amd64.tar.xz

It produced this output:
No such file or directory. Error is not recoverable. Exiting now.

My web server is (include version):
AWS

The operating system my web server runs on is (include version):
Bitnami

My hosting provider, if applicable, is:
AWS

I can login to a root shell on my machine (yes or no, or I don’t know):
yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi,

From that page you referred, there’s actually a line stating an action is needed…

Run the following commands to install the Lego client. Note that you will need to replace the X.Y.Z placeholder with the actual version number of the downloaded archive:

In this case, you should run the following command:

cd /tmp
curl -s https://api.github.com/repos/xenolf/lego/releases/latest | grep browser_download_url | grep linux_amd64 | cut -d '"' -f 4 | wget -i -
tar xf lego_v1.0.1_linux_amd64.tar.gz
sudo mv lego /usr/local/bin/lego

Thank you


#3

Thank you for response. I have got through to step 2 here

https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/

Its come up with error: ‘address already in use’

Im presuming this is because I have already gone through this process before. Could you please advise next step from hear? Is it to go onto Step 3 in the above link or something else?

Thanks in advance


#4

Hi,

That brings the question, did you use the bitnami builted Apache? Or you installed your own through yum / apt ?

Did you run this command before running Lego?
sudo /opt/bitnami/ctlscript.sh stop (if so, what’s the output?)

Thank you


#5

Thanks for response. Pulling my hair out here as site has been down for 24 hours now

Im using Apache.

I’ve gone back into the terminal. Im such a novice at this that I don’t know whether I can just start off where I was or not?

If I run sudo /opt/bitnami/ctlscript.sh stop it comes up with Syntax error on line 46

As an aside, is there any way to paste into terminal - Im on mac and tried ‘CMD V’ “SHIFT-CMD-V” and right click V

Really appreciate your help


#6

My screen now if I try from step 1


#7

OK Im back to where I was yesterday. Address already in use error?

Please could someone advise?


#8

Line 46 of what file, does it say?


#9

See attatched


#10

So it’s complaining about /opt/bitnami/apache2/conf/server.crt - does that file exist? What’s the output of:

ls -l /opt/bitnami/apache2/conf/server.crt

If it’s not there, if you or someone followed that tutorial before, there may be a /opt/bitnami/apache2/conf/server.crt.old that you can copy back temporarily just so you can go through the rest of the tutorial.


#11

Just checked. Folder exists, but file doesn’t.

Sorry for the newbie question, but how to I copy the old file over? And will this not lead to an issue later?


#12
cp -i /opt/bitnami/apache2/conf/server.crt.old /opt/bitnami/apache2/conf/server.crt

If you follow the rest of the tutorial, you’ll see there’s a step to remove it and replace it with a link to a valid certificate later. It just needs to be in place for that first part of step 2.


#13

Thanks. Its coming up with permission denied though…


#14

Try it with sudo then:

sudo cp -i /opt/bitnami/apache2/conf/server.crt.old /opt/bitnami/apache2/conf/server.crt

#15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.