AutoSSL did not renew the certificate because .well-know/acme-challenge file is missing

Hello there, I just got an automated email saying " The “LetsEncrypt” AutoSSL provider could not renew the SSL certificate without a reduction of coverage because of the following problems"

1. DNS DCV: The DNS query to “_cpanel-dcv-test-record.iphone-to-pc.com” for the DCV challenge returned no “TXT” record that matches the value “_cpanel-dcv-test-record=Eu4fz8Tu8l6DTAzef4tFKwLi3zpsfXPdk4vzRUqsC1aVq0R9Fv1nPoG0gWo0wgMH”.; HTTP DCV: The system queried for a temporary file at “http://www.es.iphone-to-pc.com/.well-known/acme-challenge/1NC2BRAXVDOFQ13ENSIB-H6OSTDS12W3”, but the web server responded with the following error: 404 (Not Found). A DNS (Domain Name System) or web server misconfiguration may exist. The domain “www.es.iphone-to-pc.com” resolved to an IP address “50.87.28.87” that does not exist on this server.

2. DNS DCV: The DNS query to “_cpanel-dcv-test-record.iphone-to-pc.com” for the DCV challenge returned no “TXT” record that matches the value “_cpanel-dcv-test-record=Eu4fz8Tu8l6DTAzef4tFKwLi3zpsfXPdk4vzRUqsC1aVq0R9Fv1nPoG0gWo0wgMH”.; HTTP DCV: The system queried for a temporary file at “http://es.iphone-to-pc.com/.well-known/acme-challenge/N7LDB24MZURAUFXD8UEYH51QXIW-BYR9”, but the web server responded with the following error: 404 (Not Found). A DNS (Domain Name System) or web server misconfiguration may exist. The domain “es.iphone-to-pc.com” resolved to an IP address “50.87.28.87” that does not exist on this server.

My domain is: www.es.iphone-to-pc.com

I ran this command:

It produced this output:

My web server is (include version): Apache 2.4.43

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: JustHost

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Can anybody please help?

1 Like

Hi @nick008

please read your output:

Your ip address - https://check-your-website.server-daten.de/?q=es.iphone-to-pc.com

Host Type IP-Address is auth. ∑ Queries ∑ Timeout
es.iphone-to-pc.com A 50.87.28.87 Provo/Utah/United States (US) - Unified Layer Hostname: 50-87-28-87.unifiedlayer.com yes 1 0
AAAA yes
www.es.iphone-to-pc.com A 50.87.28.87 Provo/Utah/United States (US) - Unified Layer Hostname: 50-87-28-87.unifiedlayer.com yes 1 0
AAAA yes

Looks like you run that AutoSSL on the wrong ip address.

There

https://www.es.iphone-to-pc.com:2083/

is something that looks like a cPanel. But where do you run that AutoSSL?

2 Likes

Hi, thanks for the quick reply. That IP address (50.87.28.87) looks correct to me. It is the dedicated IP I’m using on this domain. Everything was running smoothly for about 1.5 years, and I did not make any changes recently.

I’m sorry, it is a cPanel indeed. Version 86.0 (build 24). I tried to access that “.well-known/acme-challenge” directory and it was empty. Is this what causing this error?

1 Like

If this

is your correct ip address, your cPanel has an error.

Then your hoster must fix it.

2 Likes

I will contact my hosting provider and let them know. Thanks again for the help.

Hi, I contacted my hosting provider and this is what they have to say:

As I have checked the website is loading with SSL secure padlock and acount is enabled with SSL
refer link: https://www.sslshopper.com/ssl-checker.html#hostname=https://www.de.iphone-to-pc.com/

As per the warning emails I’m getting on email address, my SSL is already expired:

“At the time of this notice, the certificate expired -2 days, 19 hours, 26 minutes, and 8 seconds ago.”

But the SSL is working fine. Is it safe to ignore these emails?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.