Authenticator could not be determined or is not installed


#1

First of all: I write this post for the 2nd time - 1st time it said “new users only 2 links per post”, so I removed one. Then it said “couldn´t load your topic” and everything was gone. Damn it! Now only the essential text:

To my real problem:

Did skip the questions when running ./letsencrypt-auto for the first time after it was newly build/compiled.

Tried my renew command (which already worked perfectly):

sudo ./letsencrypt-auto --renew certonly --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory -d domain.name --rsa-key-size 2048 --renew-by-default --standalone-supported-challenges tls-sni-01 >> /home/pi/tools/letsencrypt_renewcert.log

Now I got the “authenticator could not be determined or is not installed” error.

Any ideas?
What can I do?


#2
  • Did I delete the configuration? Is there something important stored in “/root/.local/share/letsencrypt”? I still have the old content of this directory by the way (did rename it as already mentioned above).
  • I also found https://github.com/letsencrypt/letsencrypt/issues/1154 where the same error was posted somewhere, but can´t adopt the solution to my scenario.

HELP !