Authenticator could not be determined or is not installed


#1

Hi,

initially succesfully enrolled my certificate in November. Scheduled a cron for renewing it automatically. Cron ran today, but letsencrypt-auto failed with exactly the same problem like here (maybe because of a distribution upgrade of the linux os done meanwhile, it probably broke the python virtual environment):

[LINK HERE]

So I followed the proposed solution of this topic (but didn´t remove the folder, I just renamed it). So after running ./letsencrypt-auto again for the first time after it was recompiled (without any parameters), I ended up on the dialog:

No names were found in your configuration files. You should specify ServerNames in your config files in order to allow for accurate installation of your certificate. If you do use the default vhost, you may specify the name manually. Would you like to continue?

So I stopped this “create a new certificate process”, because the certificate still exists - I still only want to renew it. Therefore I gave the renew command line a try:

sudo ./letsencrypt-auto --renew certonly --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory -d domain.name --rsa-key-size 2048 --renew-by-default --standalone-supported-challenges tls-sni-01 >> /home/pi/tools/letsencrypt_renewcert.log

This time it gave me: “authenticator could not be determined or is not installed

I´ve got no idea what´s wrong here and how I could fix that.

==> Any ideas?
==> Any logs you need to take a look at?


#2

one thread is enough.


#3

Definitely. But this forum software seems to be a lil bit buggy: When trying to post this thread it told me “page not found” --> so I thought my post was lost (was not shown in the list) and created it again. But this one is the first one and therefore contains more detailed information.

Enough meta talk, I need help!


#4
  • Did I delete the configuration? Is there something important stored in “/root/.local/share/letsencrypt”? I still have the old content of this directory by the way (did rename it as already mentioned above).
  • I also found https://github.com/letsencrypt/letsencrypt/issues/11544 where the same error was posted somewhere, but can´t adopt the solution to my scenario.
  • Do I need to have an existing config file? Renewal worked without it by passing all the arguments as command parameters.
  • Is it maybe just a simple authenticator parameter missing?!?

HELP!


#5

Hello @bcutter

If you are using that command, you forgot to specify the authenticator -a standalone.


#6

Hi & thanks a lot @sahsanu. Was as simple as that… the broken python environment made me think of a more complicated reason and therefore a more complicated solution :smile:

Didn´t have to use the “-a standalone” when enrolling the certificate… anyway, back and running.