Certbot-auto renew error


#1

Please fill out the fields below so we can help you better.

My domain is:
www.ne2usa.com
I ran this command:
./certbot-auto renew
It produced this output:
Error: couldn’t get currently installed version for /root/.local/share/letsencrypt/bin/letsencrypt:
Traceback (most recent call last):
File “/root/.local/share/letsencrypt/bin/letsencrypt”, line 7, in
from certbot.main import main
File “/root/.local/share/letsencrypt/local/lib/python2.7/dist-packages/certbot/main.py”, line 11, in
import zope.component
File “/root/.local/share/letsencrypt/local/lib/python2.7/dist-packages/zope/component/init.py”, line 16, in
from zope.interface import Interface
ImportError: No module named interface

My operating system is (include version):
4.4.35-33.55.amzn1.x86_64

My web server is (include version):
Server version: Apache/2.4.23 (Amazon)
Server built: Jul 29 2016 21:42:17

My hosting provider, if applicable, is:
godaddy
I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no


#2

The thread - Getting “Error: couldn't get currently installed version for letsencrypt” when trying to renew my certificates should hopefully explain this issue I think.

If you remove some of the conflicting files

rm -rf “${XDG_DATA_HOME:-~/.local/share}/letsencrypt”

Then try again, it will hopefully resolve your issue.


#3

Great! Thank you very much! That worked.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.