Apache blocking port 80?


#1

Due to the change in no longer TLS-SNI-01 I followed the instructions (How to stop using TLS-SNI-01 with Certbot) and failed on the dry run. The problem was that it couldn’t bind to port 80. It seems that apache was using port 80 already.

I ended up just stopping apache and changing it to listen on port 8000. I only had it setup for some other verification calls. My question (and I understand this may not strictly be a LE question) is; Did I not setup apache right or if I wanted to leave it listening on port 80 would I have to instead use the DNS-01 challenge instead of the http-01? Is there a benefit to using one over the other, or conversely any drawbacks?

This is on an Ubuntu (16.04) using certbot. I am still fairly green on most of this so I just wanted to make sure I had a my bases covered.

Thanks


#2

Hi @azazael

you can use the webroot - authenticator. Perhaps your config has the standalone option, so Certbot starts a new webserver.

But you can use webroot with your existing webserver.


#3

Thanks I will look into that on their site.


closed #4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.