Another How to config certbot with Cloudflare


#1

Hi, I’m following the doc and I can’t make cloudflare go to the proper https route. First than anything, in that documentation where it says Credentials, what am I supposed to do? You left everything in blank to the imagination?

The path to this file can be provided interactively or using the --dns-cloudflare-credentials command-line argument.

Ok… so what do I do? When I type --dns-cloudflare-credentials on ~ dir, it doesn’t do anything…

I went and created the full firectory .secrets, etc and applied the 600 permission, now where do I put this:

certbot certonly \
  --dns-cloudflare \
  --dns-cloudflare-credentials ~/.secrets/certbot/cloudflare.ini \
  -d example.com \
  -d www.example.com

Am I supposed to put it in the nginx configuration of the site? Where?

Thank you, it just frustrating everytime I try to do something and I have to read documentations that are apparently made for who ever created it and not for the public.

EDIT: Never mind, it magically works not, the only thing different was the api on the ini and the permissions … I haven’t touch anything on the conf of the nginx… does it work? yes, is it correct? no idea… congrats to the inept that did that doc…


#2

Hi @Arturo_x

if you use the certonly - option, then you get only the certificate, no local installation. If you use --dns-cloudflare as authenticator, you don’t need a local webserver. So it’s irrelevant to your nginx-configuration.

If you are running a local nginx, why don’t you use that? If you don’t want a wildcard certificate, you may use http-01 - validation instead of dns-01 - validation.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.