Certbot not installing configuration into nginx when using CloudFlare plugin

My domain is: ideaman924.com

I ran this command: certbot certonly --dns-cloudflare --dns-cloudflare-credentials ~/.secrets/cloudflare.ini -d ideaman924.com -d *.ideaman924.com -i nginx

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator dns-cloudflare, Installer nginx
Obtaining a new certificate
Performing the following challenges:
dns-01 challenge for ideaman924.com
dns-01 challenge for ideaman924.com
Waiting 10 seconds for DNS changes to propagate
Waiting for verification...
Cleaning up challenges

IMPORTANT NOTES:
 - Congratulations! Your certificate and chain have been saved at:
   /etc/letsencrypt/live/ideaman924.com/fullchain.pem
   Your key file has been saved at:
   /etc/letsencrypt/live/ideaman924.com/privkey.pem
   Your cert will expire on 2020-05-05. To obtain a new or tweaked
   version of this certificate in the future, simply run certbot
   again. To non-interactively renew *all* of your certificates, run
   "certbot renew"
 - If you like Certbot, please consider supporting our work by:

   Donating to ISRG / Let's Encrypt:   https://letsencrypt.org/donate
   Donating to EFF:                    https://eff.org/donate-le

My web server is (include version): nginx version: nginx/1.14.2

The operating system my web server runs on is (include version): Debian 10.2

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine: Yes

I’m using a control panel to manage my site: No

The version of my client is: certbot 0.31.0

Basically what the title says. After installation, certbot does not modify the nginx server configuration directives, even if I pass the -i nginx command-line parameter. Therefore, SSL on nginx remains broken and the website does not pass the SSL test. What am I doing wrong?

1 Like

Hi @ideaman924

why do you use certonly? certonly -> no installation. Your command is wrong. Mixing certonly with -i - that’s curious.

Try something like --reinstall -d yourdomains -i nginx. Certbot should find the certificate and should install it.

But a working port 80 with the same list of domain names is required.

2 Likes

Yup, that worked, thank you! Ran certbot --reinstall -d ideaman924.com -d *.ideaman924.com -i nginx and it properly led me through the steps to correctly install the new configuration. Thank you so much!

The reason I used certonly is because it says so on the documentation: https://certbot-dns-cloudflare.readthedocs.io/en/stable/#id2. It also says to append -i nginx to this command on the EFF’s page: https://certbot.eff.org/lets-encrypt/debianbuster-nginx

Run one of the commands in the “Examples” section of the instructions for your DNS provider, along with the flag -i nginx.

Maybe the documentation needs to be updated? I may have just understood it wrong, sorry! Thanks again for helping me out :smiley:

3 Likes