Alternative name missing and Certificate error. Google Cloud VM Apache CentOS7

My domain is: www.gcp-example-bot.com

I ran this command: sudo certbot --apache
and then “sudo service httpd graceful”

It produced this output:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Which names would you like to activate HTTPS for?
-------------------------------------------------------------------------------
1: www.gcp-example-bot.com
-------------------------------------------------------------------------------
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1
Cert not yet due for renewal
You have an existing certificate that has exactly the same domains or certificate name you requested and isn’t clos
e to expiry.
(ref: /etc/letsencrypt/renewal/www.gcp-example-bot.com.conf)
What would you like to do?
-------------------------------------------------------------------------------
1: Attempt to reinstall this existing certificate
2: Renew & replace the cert (limit ~5 per 7 days)
-------------------------------------------------------------------------------
Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 1
Keeping the existing certificate
Deploying Certificate for www.gcp-example-bot.com to VirtualHost /etc/httpd/conf.d/ssl.conf
Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.
-------------------------------------------------------------------------------
1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you’re confident your site works on HTTPS. You can undo this
change by editing your web server’s configuration.
-------------------------------------------------------------------------------
Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2
Enhancement redirect was already set.
-------------------------------------------------------------------------------
Congratulations! You have successfully enabled https://www.gcp-example-bot.com
You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=www.gcp-example-bot.com
-------------------------------------------------------------------------------
IMPORTANT NOTES:
- Congratulations! Your certificate and chain have been saved at:
/etc/letsencrypt/live/www.gcp-example-bot.com/fullchain.pem
Your key file has been saved at:
/etc/letsencrypt/live/www.gcp-example-bot.com/privkey.pem
Your cert will expire on 2017-12-19. To obtain a new or tweaked
version of this certificate in the future, simply run certbot again
with the “certonly” option. To non-interactively renew all of
your certificates, run “certbot renew”
- If you like Certbot, please consider supporting our work by:
02 4 * * * /bin/certbot renew --quiet
Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
Donating to EFF: https://eff.org/donate-le
$

My web server is (include version): google cloud compute engine, VM Apache/2.4.6

The operating system my web server runs on is (include version): CentOS7

My hosting provider, if applicable, is: domains.google.com
attached image is DNS settings. That is the only setting i configured.
google DNS A record setting

I can login to a root shell on my machine (yes or no, or I don’t know): yes i can SSH

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): not sure

The problem
the problem im having is, after running Certbot on my VM apache and getting certs.
my site . https://www.gcp-example-bot.com does not have SSL still. when you see the site, I am running a “placeholder” index.html from the VM apache.
Inspecting the page > Security tab > i have “Subject alternative name missing” and “Certificate error” even though i successfully ran the Certbot.

why can’t i get HTTPS on my site?

I can’t access your site at all currently. :slightly_frowning_face: Please fix it so we can see what might have gone wrong.

2 Likes

Same here, completely dead.

Sorry. vm server is up now.

[fixed].
was domain routing problem. i followed.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.