After SSL Issue, IIS Site is not working

Hi ,

My Domain: cspservice.kitcodms.in

I had used Win Acme Version 2.0.1

I had binded the site using default port
after that i had generated ssl using single site binding
ssl generated and binded with my site
after that my site is not accessible through https. I had opened the port in firewall and still no luck

iam not that experienced with this. It is still working with non ssl.

Regards,

Sreekanth.

Hi @sreekanth850

your configuration is curious. See https://check-your-website.server-daten.de/?q=cspservice.kitcodms.in

You have two different ip addresses:

Host T IP-Address is auth. ∑ Queries ∑ Timeout
cspservice.kitcodms.in A 111.93.118.188 Kochi/Kerala/India (IN) - Ttsl-isp Division Hostname: static-188.118.93.111-tataidc.co.in yes 1 0
AAAA yes
www.cspservice.kitcodms.in A 199.16.131.208 Montreal/Quebec/Canada (CA) - PlanetHoster Hostname: world-219.ca.planethoster.net yes 1 0
AAAA yes

one in India, the other in Canada.

You have two valid certificates:

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2020-03-31 2020-06-29 cspservice.kitcodms.in - 1 entries duplicate nr. 1
Let’s Encrypt Authority X3 2020-03-31 2020-06-29 www.cspservice.kitcodms.in - 1 entries duplicate nr. 1

both created today.

Both http are working:

Domainname Http-Status redirect Sec. G
http://cspservice.kitcodms.in/ 111.93.118.188 GZip used - 1265 / 3019 - 58,10 % 200 Html is minified: 124,80 % 0.470 H
http://www.cspservice.kitcodms.in/ 199.16.131.208 No GZip used - 422 / 801 - 52,68 % possible 200 Html is minified: 107,52 % 0.243 H
https://cspservice.kitcodms.in/ 111.93.118.188 -14 10.044 T
Timeout - The operation has timed out
https://www.cspservice.kitcodms.in/ 199.16.131.208 No GZip used - 422 / 801 - 52,68 % possible Inline-JavaScript (∑/total): 0/0 Inline-CSS (∑/total): 0/0 200 Html is minified: 107,52 % 4.650 B

https + non-www has a timeout.

Non-www is an IIS/8.5, www is an Apache.

Share a screenshot with your non-www binding menu.

Thank you @JuergenAuer , i had changed the ip of www.cspservice.kitcodms to 111.93.118.188

This subdomain is Pointed to an IIS server for accessing a .net Web Application.

Screenshot of non SSL binding is attached.

1 Like

First, your http works, your https binding is required.

Second: Do you need the Default Web Site? If not, stop it. Then you can use that site as default site.

Third: Don’t use ip addresses. May be a problem if your server is connected via another ip address.

I had stopped default website.

.

Third: Don’t use ip addresses: That mean i need to keep it as un assigned?

If you use a host name, the check of “SNI” is required.

Works https internal?

curl https://cspservice.kitcodms.in/

from that machine? If yes, it’s a firewall or routing problem.

it is not working internally also. when i check sni iis throwing a warning saying that ssl is not default ssl site has been created.

Iam also not able to browse the http url or access the site with ip address from internal machine i.e local machine also. Is my setting in host file missing?

Problem solved, it was not enabled in server. i mean port 443

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.