_acme-challenge. not propagating

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: poolforcellc.com

I ran this command:

It produced this output: enter email - then I opted ‘N’ on the logging.
I was supposed to get two TXT records but now nothing.
How do I go about this?

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: aws

I can login to a root shell on my machine (yes or no, or I don’t know): YES

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): 0.31.0

You mean when it asks about logging your IP address? You have to answer Y to that. It's a warning, not an option. It's mainly intended for people running certbot on a machine other than their web server who might not realize that the other machine's IP address will be logged too, but since it can't proceed otherwise, it gives you a chance to stop the entire procedure and run certbot on the web server instead.

Thank you for the prompt response. Correct I meant the logging of IP address. How do I re-run that part only?

I ran ‘sudo certbot -d $DOMAIN -d $WILDCARD --manual --preferred-challenges dns certonly’
nut had a ‘certbot: error: argument -d/ – domains/ --domain: expected one argument’

Note: I had ran that before and it was successful.

Are you sure the $DOMAIN and $WILDCARD variables are set correctly?

Also you should probably put them in double quotes e.g. "$WILDCARD"

The $DOMAIN and $WILDCARD wasn’t correct. I started the whole process again now I’m back on track. Thank you again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.