Access forbidden!

My domain is:

I ran this command: sudo certbot --apache

It produced this output: Access forbidden!

You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

My web server is (include version): Ubuntu 18.04, Apache2

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.31.0

It looks like you have two Apache versions. The Ubuntu one and one in Win64. The Win64 one looks to not authorize requests to the index page.

I don't see any evidence of a Let's Encrypt cert being used (yet). What did the certbot output say about getting the cert?

curl -I

HTTP/1.1 200 OK
Date: Sun, 22 May 2022 02:58:43 GMT
Server: Apache/2.4.29 (Ubuntu)
Set-Cookie: suyudi=htr1fus84nea97ud67ntfr19en; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
Content-Type: text/html; charset=UTF-8

curl -Ik
(Note: -k is needed due to self-signed, expired, cert)

HTTP/1.1 403 Forbidden
Date: Sun, 22 May 2022 02:58:58 GMT
Server: Apache/2.4.41 (Win64) OpenSSL/1.1.1c PHP/7.2.22
Vary: accept-language,accept-charset
Accept-Ranges: bytes
Content-Type: text/html; charset=utf-8
Content-Language: en

This is the last part after i install letsencrypt.

Maybe apache win64 from the network settings device. Any advice for this problem ?

Make sure port 443 is forwarded to the same server as port 80


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.