500: Interval Server Error in options-ssl-nginx.conf; Rate limit

Hello,

When I try to make certificate I get this error:

An unexpected error occurred:
There were too many requests of a given type :: Error creating new order :: too many certificates already issued for exact set of domains: websitetest.ch,www.websitetest.ch: see https://letsencrypt.org/docs/rate-limits/


Last night I tried to generate certificate couple of times but there was couple of errors:

First:
When I tried to download script called from this link

https://raw.githubusercontent.com/wmnnd/nginx-certbot/master/init-letsencrypt.sh

I get 500 Internal error. Hour later this link worked and the script is in there, do you know something about it?

Second:
After link worked I generated new certificate and its says that is generated successfully, but when in log file I saw one error regarding options-ssl-nginx.conf.

I tried to open this options-ssl-nginx.conf file and its content was:

500: Internal Server Error

here is the screenshot: https://i.ibb.co/nrMwCvY/img.jpg

After that I tried to generate certificate couple more time and this morning is when the Rate limit error occurred.

Can you guys help me anyhow to solve this problem?

this is pretty strange. what shell are you using? a web based one?

this is expected. use the certificates you already have.

We use standard mac shell, not web based one.
We did this number of times (on different projects not on this one) but this is the first time that this error occurred.

We deleted certbot docker container that contained certificate so we do not have any at the moment.
Do you know when this Rate limit will be over so we can try again?

One week. (on a rolling window)

You can also add another [sub]domain to the certificate to bypass this ratelimit.

And always use a volume for the damn certificates and keys.

Oh, I know why. Your script downloads that file from github and doesn’t check the http return code. It was probably github having problems. Let’s hope this solves the problem: https://github.com/wmnnd/nginx-certbot/pull/66

@9peppe Thank you for answering.

We managed somehow to fix options-ssl-nginx.conf file but now we are facing with the problem that we could not retrieve our certificate keys.
We deleted certbot docker image and container while debugging in which we had fullchain.pem and privkey.pem. We tried now but we can not revive them anyhow.

Can we write to letsencrypt support so they can provide us / generate for us new certificates, what do you think?

We know that we have to wait 7 days but that is too long…

Add some other [sub]domain to the certificate to get around this rate limit (it must validate correctly)

check the directories, like ./data

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.