Your DNS look up

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain

I ran this command:
certbot certonly --webroot -w /Library/Server/Web/Data/Sites/Default/ -d --rsa-key-size 4096 -m

It produced this output:

The following errors were reported by the server:

Type: connection
Detail: Fetching
Error getting validation data

My web server is (include version):

The operating system my web server runs on is (include version):
OS X Server 10.12
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

My Public IP is 10814 IN A sends an HTTP redirect to sends an HTTP redirect to

The redirects have different Server headers and different HTML, too.

Something’s off with the configuration in one of your web servers.

Presumably it’s a web server running on, and it might be redirecting to the SERVER_NAME variable.

Let’s Encrypt is okay with a redirect to HTTPS, but that hostname won’t work.

1 Like

Even though you server has a wrong redirect the IP is a Japanese domain you were correct in that there was a redirect so sorting

William Bowden | JMRIT Consultants

Consultant Engineer | m:07525 645105 | names are in the opposite byte order as IPv4 addresses are usually represented, so is for, which is a private address.

Still not my WAN IP set in DNS how odd

<<>> DiG 9.10.6 <<>> @

; (1 server found)

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51149

;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1


; EDNS: version: 0, flags:; udp: 512


; IN A


;; Query time: 66 msec


;; WHEN: Thu Oct 25 16:46:27 BST 2018

;; MSG SIZE rcvd: 65

William Bowden | JMRIT Consultants

Consultant Engineer | m:07525 645105 |

It is, but the web server running on that IP sends a redirect to the other URL.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.