I got a huge problem with CertBot

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: 16Adrenaline.ddns.net

I ran this command: Certbot certony --standalone

It produced this output: Says no IP addresses found for domain when my Apache is off.

My web server is (include version): Apache

The operating system my web server runs on is (include version):
Windows 10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):
I don't know
I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Your hostname resolves to a private IP address:

16Adrenaline.ddns.net.	60	IN	A

A few things:

  1. Is it really necessary to use the --standalone plugin? As far as I know, the --webroot plugin also works on Windows (not sure about the --apache plugin though, can't find it in the documentation......)
  2. The --standalone plugin (and the --webroot plugin too by the way) uses the http-01 challenge, which requires a publicly available IP address to connect to by the Let's Encrypt validation server. If you don't or can't use a publicly available IP address, you could try to use the dns-01 plugin.
  3. "root" is the superuser on Linux/Unix systems, which would be "Administrator" rights on a Windows system.
  4. You should know the answer to the control panel question and the client version question.
  5. Please copy/paste the entire output if requested, although for now we have enough information.

But when I use the --webroot, I'm too stupid know what my site webroot is.

It's the path configured by the DocumentRoot directive in Apache. But standalone or webroot isn't your biggest problem: if you want to use either plugin, you need to fix the IP address first.

so how do i fix the ip address?

It seems you're using no-ip's dynamic DNS system. I don't have experience with that, but you should somehow configure your dynamic DNS software to use the public IP address of your internet connection in stead of the private IP address of the computer. Also, remember that port 80 and port 443 should be portmapped to your local computer in your NAT router, if applicable. And all firewalls need to be open for port 80 and 443.

okay, i turned my firewall off. and what do i do for other thing you recommended?

I would not advice to turn the entire firewall off.. Only ports 80 and 443 are required to be open.

I don't know, please check the documentation of the dynamic DNS software you're using for your ddns.net hostname.

okay for my router i also tried turning my port forwarding to HTTP or HTTPS. i going to see if it works.

As long as your hostname still resolves to your private IP address, it's not going to work.

my router asks for my local. which is 192. but my public doesn't work.

I don't understand. You're speaking about your router.. Are you talking about the port forwarding? Because I wasn't. I was talking about the DNS configuration of your hostname, as I specified in my first post in this thread.

oh i was talking about port forwarding. thing is i dont even know what DNS configuration of hostname. does it have something to do with the config in apache.

im starting off a few youtube videos, so i ask that you please be patient with me. the reason why I want an SSL is because I want to put Cloudflare or OVH on the site as a learning experience.

Your hostname is 16adrenaline.ddns.net. You somehow acquired that hostname, probably through ddns.net or perhaps no-ip.com. You need to change the DNS settings for your hostname somehow, perhaps through ddns.net or no-ip.com too, I don't know.

No, Apache is a webserver. It does not do DNS things.

i dont really see a problem on no ip.com its the same ip as my local ip.

That is the problem: it should show your public IP address, not local.

well thats really weird, my router wouldn't let me port forward my public ip tho.

But your router isn't no-ip.com? Those are two different things? Or am I missing something?

wait am i only supposed to use no ip?