Your connection is not secure warning for wildcard certs


#1

I have generated the cert in one docker host and copied the cert and private keys to server running apache and another server running ngnix.

My domain is: btrnaidu.com

I ran this command: ./certbot-auto --server https://acme-v02.api.letsencrypt.org/directory -d *.elvero.nl -d *.view-my-ip.com -d *.dns-point.com -d *.vpn-spot.com -d *.btrnaidu.com -d *.amstar.in -d *.amstar.co.in -d *.amstar.org -d *.amstartechnologies.co.in -d *.sweconsulting.com -d *.insafehands.co.in -d *.lmcentraal.com -d *.indiaradar24.com -d *.ios.training -d *.wolknet.com --manual --preferred-challenges dns-01 certonly --expand

It produced this output: Congratulations! Your certificate and chain have been saved at...

My web server is (include version): Apache and ngnix

The operating system my web server runs on is (include version): Ubuntu

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

Hi @naidu,

Wildcard certs like *.btrnaidu.com only cover subdomains like a.btrnaidu.com, b.btrnaidu.com etc. but don’t cover neither a.b.btrnaidu.com nor the base domain btrnaidu.com. So if you want to cover the base domains then you need to add them to the certbot command.

Cheers,
sahsanu


#3

Interesting. And it worked. Thanks :smile: :+1:


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.