'Your connection is not private' for pictures on wordpress

My domain is: marketstrategy.de

I ran this command: https://www.ssllabs.com/ssltest/analyze.html?d=marketstrategy.de

It produced this output: A

My web server is (include version): apache2 2.4
The operating system my web server runs on is (include version): ubuntu 14.04 lte

My hosting provider, if applicable, is: hetzner

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): wordpress 4.9.2

Like you can see, All images on my website can’t be displayed alltough let’s encrypt is installed correctly. I checked my site for mixed content and went through all pages, replacing http with https.
haalp :slight_smile:

This is a slightly subtle one: the images are served from https://www.marketstrategy.de/ rather than http://marketstrategy.de/. Your certificate is only valid for marketstrategy.de, not for www.marketstrategy.de, so browsers refuse to load the image resources from the other domain because they view its certificate as invalid. These are separate names, and you should obtain a certificate that covers both of them.


that did the trick, thanks! Is there a way to issue to certificate to both https://… and https://www… ? I simply changed all links and images now but didn’t feel as if I did the most smart way :smiley:

Yes, this is extremely common. What client software are you using to issue the certificate?

Apache, if you mean this. I simply followed this tutorial to do get the certificates: https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-14-04

So I’d simply need to reissue the certs with
sudo certbot --apache -d marketstrategy.de -d www.marketstrategy.de

That should probably work!

1 Like

The reason is because you need your Site Address and WordPress address in settings to have https in front of us. I had this same problem, just make sure it has HTTPS in front.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.