WordPress Error - Trouble with Let's Encrypt


#1

Though I already found similar threads in the forum, I couldn’t find the appropriate solution for it.

I added a Let’s Encrypt certificate to my VPS Server hosted website using the installation icon in cPanel.

Though I tested that it was working through a couple of SSL checker sites and it passed. I even put Cloudflare to maintenance mode so it doesn’t add any extra problems.

I even altered my website’s address from http to https. I then tried to access the website via https and I got the following error:

"

This site can’t provide a secure connection

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Unsupported Prototcol

The client and server don’t support a common SSL protocol version or cipher suite.

"

I cannot access the WP Dashboard now and need to do the setup. What can I do?


#2

Hi @alexbach420

what’s your domain name?


#3

I cannot share it because of privacy reasons. However, if you could suggest me some fixes, then it’ll be great.


#5

Those “fixes” usually depend on the actual state of the server (domain)… And wrong advices might make things even worse…


#6

Did you install the certificates via cPanel?

Could you elaborate more on “maintenance mode” for CloudFlare and the setup(tls, CDN) of CloudFlare?

Thank you


#7

Yes, I installed them my hosting’s cPanel.

You can check it here about the Maintenance mode if you haven’t tried CloudFlare previously.


#8

Hi Alex, I think the problem is not with your domain or CloudFlare. But it’s a browser error. It is basically a miscommunication indicator which tells that the web browser you are using and the web server is unable to exchange details.

You can check the following link to fix Err_SSL_Version_Or_Cipher_Mismatch Error.

Revert back if the issue is still not resolved.


#9

Thank you so much. I lost all my hopes but someone finally replied to the forum.