Windows VM on Google Cloud expired certificate and cannot access trough Remote Desktop

SSL certificate expired today. I’m trying to access the server through Remote Desktop to attempt to renew but I cannot get in, getting a warning that I’m being disconnected due to a protocol error (code 0x112d). I assume this is due to the expired certificate. Please, I need to restore access to the site ASAP, whether renewing or removing the expired certificate. By now and because of the certificate expiration, the web browser warns users about the issue on each and every page they try to access, and this makes the site (is a web application) unusable.

My domain is: e-consorcio.com

I ran this command:

It produced this output:

My web server is (include version): Google Cloud Platform

The operating system my web server runs on is (include version): Windows Server 2012

My hosting provider, if applicable, is: Google

I can login to a root shell on my machine (yes or no, or I don’t know): I know I can access through Cloud Shell (but I don’t know how to use it)

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Google Cloud

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @ratalinux

checking Google there are some things you may check.

But it’s normally not a certificate problem. RDP accepts minimal self signed certificates, so an expired certificate should be ok.

PS: Try to create a new connection, don’t use an existing config file. May be some settings are wrong.

Thanks Juergen, but seems like that didn’t worked. Already tried to create a new connection, without config file, with config file, reseting the password through Google console, but nothing worked. Both events (cert expiration and RDP not letting me in) ocurred at the same time, that’s why I’m assuming that’s the reason.

Is it possible to use another client? What’s your client? Up to date?

Allows Google another type of connection, ssh or something else?

Is it possible to use another pc / tablet to connect?

PS: Tested your RDP, there is a regular answer.

Yes, my client is up to date and it’s working fine when I use it to connect to other servers.

Google allows to connect through their Cloud Shell console (command line tool), which I doesn’t have a clue about how it works.

I obviously googled about my issue and it seems like I should certainly expect what I’m going through when my SSL cert expires, since it treats my login attempt as a possible attack. Some of them points the solution on about trying to open a certain port and try to connect through there, but that’s like a little too advanced for my knowledge level.

I hope there’s an easier solution, at least to connect to my web server again.

I don’t think that’s the reason.

RDP uses typically self signed certificates, not the certificates of your webserver. So your webserver certificate is completely irrelevant.

Did you try the RDP of the Microsoft Store? And what’s your client? Windows 7? That’s expired.

PS: A Windows RDP forum may be more helpful.

My client is Win 10.

I’ll take your advice and dig a little more on RDP forums. Probably the events aren’t related and it’s just a curious coincidence.

Thanks for your assitance!

Hi Juergen, just to let you know… as you said, issues weren’t related. After an instance restart, now I have access to the server through RDP.

Thanks again :slight_smile:

1 Like

Ah, thanks, good to know. There are some error messages, all with bitmap- and other graphic problems. Or an untypical background image.

So a restart cleans the cache.

Thanks for reporting back :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.