WinAcme 2.1.4.710 renews but expiry doesn't change

After “succeeding” to renew my certificate about 4 times, i notice the same expiration date on the certificate info of my website. This was after clearing the browser cache on multiple devices. Not very versed in this at all but I am beginning to panic due to certificates no longer being issued from older clients; which poses a problem because the only way I managed to get my certificate reinstated after revoking and creating one all over again (same problem last time I attempted to renew) was to issue from the oldest version of win-acme that ever existed; and import the renewal into ever newer versions until current. Therefore, it feels like I’ll literally be locked out of getting a certificate through letsencrypt until I can afford a separate linux server (including maxed out outlets in my house :sweat_smile: ) just to use certbot instead of winacme … help?

My domain is: https://www.xarus.no-ip.org

I ran this command:

It produced this output:

My web server is (include version): WAMPServer 3.1.7

The operating system my web server runs on is (include version): Windows 8.1 version 6.3 (Build 9600)

My hosting provider, if applicable, is: no-ip.org

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): win-acme.v2.1.4.710.x64.pluggable

1 Like

A simple question, have you tried to restart your webserver and figure out which certificate (the absolute path) your webserver is using?
The two possible reasons I think might be

  1. Your webserver isn’t restarted to use the new certificate (if you are using the same file as your certificate client changed)
  2. Your webserver is using a copy of the certificate, instead of using the auto-updated version.
4 Likes

The cert in use expires in 18 days.
But you have definitely renewed that cert today:
https://crt.sh/?q=xarus.no-ip.org

You need to do as @stevenzhu recommends and check where the renewed certs are stored and compare to where your webserver uses certs.
Or just restart the web service / server.

3 Likes

Gonna check when I can! Definitely didn’t consider the path might’ve changed. Nervous to figure that one out but thank you for pointing me in a direction!