Win-acme: AcmeProtocolException: "Rate limit for '/directory' reached"

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):
windows 10 2004 (19041.928)
My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): win-acme.v2.0.8.356

hi all.
i use let's encrypt cert (*.pem) for my little mail server about 1.5 years. i scheduled only one cert renewal by default every 55 days (screenshot added). But on 28.03.2021 starts an error in system journal "AcmeProtocolException: "Rate limit for '/directory' reached"
Then i tried to renew cert manually to check an error and "acme" tell me that cert created but files was not generated on the disk. last cert file created 05.03.2021.
somebody have any suggestions?


1 Like

This sounds either like a bug in win-acme or a configuration issue elsewhere. The rate limit for /directory etc is 40 requests per second. Rate Limits - Let's Encrypt.

I'd expect this issue to fix itself quite quickly but it's worth upgrading win-acme just in case there is a bug as your version is a couple of years old.


thanks, i will try to update win-acme. can you tell me - if i update win-acme - i must configure a renewal of cert? or settings of renews are saved in cloud of Let's encrypt?

1 Like

Hi, I think win-acme will update it's own settings but there are possibly some migration steps:


I updated the win-acme but had to uninstall the old scheduled certificate renewal because it still didn't want to work. Then I created a new one and it seems to give out the necessary certificate files. I will also observe the performance of the new renewal

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.