Wildcard ssl with www.subdomain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: tonyslavin.com

I ran this command: I have set wild card there.

It produced this output:

My web server is (include version): Directadmin control panel

The operating system my web server runs on is (include version): centos 7

My hosting provider, if applicable, is: I host my domain on my own servers.

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): directadmin

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

I have explained all possible questions above. My problem is I have successfully added wildcard certificate on site and it works great.

The problem is I need to add this to subdomain with www prefix. So if I installed my wildcard SSL to say https://example.tonyslavin.com it works well. But if that is to https://www.example.tonyslavin.com it shows error.

As I said in your previous thread:

If you absolutely need your certificate to cover www.example.tonyslavin.com, it needs to include either www.example.tonyslavin.com or *.example.tonyslavin.com. There isn’t another option.

1 Like

Note: this isn’t a limitation of Let’s Encrypt, but the way wildcard certificates work in general.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.